summaryrefslogtreecommitdiffstats
path: root/src/pybind/mgr/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/pybind/mgr/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream/16.2.11+ds.tar.xz
ceph-upstream/16.2.11+ds.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/pybind/mgr/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/pybind/mgr/CMakeLists.txt b/src/pybind/mgr/CMakeLists.txt
new file mode 100644
index 000000000..4b915219a
--- /dev/null
+++ b/src/pybind/mgr/CMakeLists.txt
@@ -0,0 +1,34 @@
+if(WITH_MGR_DASHBOARD_FRONTEND)
+ add_subdirectory(dashboard)
+endif()
+if(WITH_MGR_ROOK_CLIENT)
+ add_subdirectory(rook)
+endif()
+if(WITH_TESTS)
+ include(AddCephTest)
+ add_tox_test(mgr ${CMAKE_CURRENT_SOURCE_DIR} TOX_ENVS py3 mypy flake8 jinjalint)
+endif()
+
+# Location needs to match default setting for mgr_module_path, currently:
+# OPTION(mgr_module_path, OPT_STR, CEPH_PKGLIBDIR "/mgr")
+install(DIRECTORY
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ DESTINATION ${CEPH_INSTALL_DATADIR}
+ REGEX "CMakeLists.txt" EXCLUDE
+ REGEX "\\.gitignore" EXCLUDE
+ REGEX ".*\\.pyi" EXCLUDE
+ REGEX "hello/.*" EXCLUDE
+ REGEX "cli_api/.*" EXCLUDE
+ REGEX "tests/.*" EXCLUDE
+ REGEX "rook/rook-client-python.*" EXCLUDE
+ REGEX "osd_perf_query/.*" EXCLUDE
+ REGEX "tox.ini" EXCLUDE
+ REGEX "requirements.*\.txt" EXCLUDE
+ REGEX "constraints.*\.txt" EXCLUDE
+ REGEX "node_modules" EXCLUDE
+ REGEX "cypress.*" EXCLUDE
+ REGEX "\.coveragerc" EXCLUDE
+ REGEX "\.editorconfig" EXCLUDE
+ REGEX "\..*lintrc" EXCLUDE
+ REGEX "\.browserslistrc" EXCLUDE
+ REGEX "\.prettier*" EXCLUDE)