summaryrefslogtreecommitdiffstats
path: root/src/rapidjson/thirdparty/gtest/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/rapidjson/thirdparty/gtest/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream/16.2.11+ds.tar.xz
ceph-upstream/16.2.11+ds.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/rapidjson/thirdparty/gtest/CMakeLists.txt')
-rw-r--r--src/rapidjson/thirdparty/gtest/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/rapidjson/thirdparty/gtest/CMakeLists.txt b/src/rapidjson/thirdparty/gtest/CMakeLists.txt
new file mode 100644
index 000000000..8d2b552ef
--- /dev/null
+++ b/src/rapidjson/thirdparty/gtest/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 2.6.2)
+
+project( googletest-distribution )
+
+enable_testing()
+
+option(BUILD_GTEST "Builds the googletest subproject" OFF)
+
+#Note that googlemock target already builds googletest
+option(BUILD_GMOCK "Builds the googlemock subproject" ON)
+
+if(BUILD_GMOCK)
+ add_subdirectory( googlemock )
+elseif(BUILD_GTEST)
+ add_subdirectory( googletest )
+endif()