summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/GNUmakefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/seastar/dpdk/GNUmakefile
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/seastar/dpdk/GNUmakefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/seastar/dpdk/GNUmakefile b/src/seastar/dpdk/GNUmakefile
new file mode 100644
index 000000000..e8de422df
--- /dev/null
+++ b/src/seastar/dpdk/GNUmakefile
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2010-2015 Intel Corporation
+
+#
+# Head Makefile for compiling rte SDK
+#
+
+RTE_SDK := $(CURDIR)
+export RTE_SDK
+
+#
+# directory list
+#
+
+ROOTDIRS-y := buildtools lib kernel drivers app
+
+include $(RTE_SDK)/mk/rte.sdkroot.mk