summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/doc/guides/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/spdk/dpdk/doc/guides/meson.build
parentInitial commit. (diff)
downloadceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.tar.xz
ceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/spdk/dpdk/doc/guides/meson.build')
-rw-r--r--src/spdk/dpdk/doc/guides/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/spdk/dpdk/doc/guides/meson.build b/src/spdk/dpdk/doc/guides/meson.build
new file mode 100644
index 000000000..732e7ad3a
--- /dev/null
+++ b/src/spdk/dpdk/doc/guides/meson.build
@@ -0,0 +1,24 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 Intel Corporation
+
+sphinx = find_program('sphinx-build', required: get_option('enable_docs'))
+
+if not sphinx.found()
+ subdir_done()
+endif
+
+htmldir = join_paths(get_option('datadir'), 'doc', 'dpdk')
+html_guides = custom_target('html_guides',
+ input: files('index.rst'),
+ output: 'html',
+ command: [sphinx_wrapper, sphinx, meson.current_source_dir(), meson.current_build_dir()],
+ depfile: '.html.d',
+ build_by_default: get_option('enable_docs'),
+ install: get_option('enable_docs'),
+ install_dir: htmldir)
+
+install_data(files('custom.css'),
+ install_dir: join_paths(htmldir,'_static', 'css'))
+
+doc_targets += html_guides
+doc_target_names += 'HTML_Guides'