summaryrefslogtreecommitdiffstats
path: root/src/zstd/build/meson/contrib/gen_html/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/zstd/build/meson/contrib/gen_html/meson.build
parentInitial commit. (diff)
downloadceph-upstream/16.2.11+ds.tar.xz
ceph-upstream/16.2.11+ds.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/zstd/build/meson/contrib/gen_html/meson.build')
-rw-r--r--src/zstd/build/meson/contrib/gen_html/meson.build30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/zstd/build/meson/contrib/gen_html/meson.build b/src/zstd/build/meson/contrib/gen_html/meson.build
new file mode 100644
index 000000000..3f302538d
--- /dev/null
+++ b/src/zstd/build/meson/contrib/gen_html/meson.build
@@ -0,0 +1,30 @@
+# #############################################################################
+# Copyright (c) 2018-present lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+zstd_rootdir = '../../../..'
+
+gen_html_includes = include_directories(join_paths(zstd_rootdir, 'programs'),
+ join_paths(zstd_rootdir, 'lib'),
+ join_paths(zstd_rootdir, 'lib/common'),
+ join_paths(zstd_rootdir, 'contrib/gen_html'))
+
+gen_html = executable('gen_html',
+ join_paths(zstd_rootdir, 'contrib/gen_html/gen_html.cpp'),
+ include_directories: gen_html_includes,
+ native: true,
+ install: false)
+
+# Update zstd manual
+zstd_manual_html = custom_target('zstd_manual.html',
+ output : 'zstd_manual.html',
+ command : [gen_html,
+ zstd_version,
+ join_paths(meson.current_source_dir(), zstd_rootdir, 'lib/zstd.h'),
+ '@OUTPUT@'],
+ install : false)