summaryrefslogtreecommitdiffstats
path: root/src/zstd/tests/gzip/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/zstd/tests/gzip/Makefile
parentInitial commit. (diff)
downloadceph-6d07fdb6bb33b1af39833b850bb6cf8af79fe293.tar.xz
ceph-6d07fdb6bb33b1af39833b850bb6cf8af79fe293.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/zstd/tests/gzip/Makefile')
-rw-r--r--src/zstd/tests/gzip/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/src/zstd/tests/gzip/Makefile b/src/zstd/tests/gzip/Makefile
new file mode 100644
index 000000000..73f62f0eb
--- /dev/null
+++ b/src/zstd/tests/gzip/Makefile
@@ -0,0 +1,45 @@
+# ################################################################
+# Copyright (c) 2017-2020, Facebook, Inc.
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# You may select, at your option, one of the above-listed licenses.
+# ################################################################
+
+PRGDIR = ../../programs
+VOID = /dev/null
+export PATH := .:$(PATH)
+
+.PHONY: all
+#all: test-gzip-env
+all: test-helin-segv test-hufts test-keep test-list test-memcpy-abuse test-mixed
+all: test-null-suffix-clobber test-stdin test-trailing-nul test-unpack-invalid
+all: test-zdiff test-zgrep-context test-zgrep-f test-zgrep-signal test-znew-k test-z-suffix
+ @echo Testing completed
+
+.PHONY: zstd
+zstd:
+ $(MAKE) -C $(PRGDIR) zstd
+ ln -sf $(PRGDIR)/zstd gzip
+ @echo PATH=$(PATH)
+ gzip --version
+
+.PHONY: clean
+clean:
+ @$(MAKE) -C $(PRGDIR) $@ > $(VOID)
+ @$(RM) *.trs *.log
+ @echo Cleaning completed
+
+
+#------------------------------------------------------------------------------
+# validated only for Linux, macOS, Hurd and some BSD targets
+#------------------------------------------------------------------------------
+ifneq (,$(filter $(shell uname),Linux Darwin GNU/kFreeBSD GNU FreeBSD DragonFly NetBSD))
+
+test-%: zstd
+ @./test-driver.sh --test-name $* --log-file $*.log --trs-file $*.trs --expect-failure "no" --color-tests "yes" --enable-hard-errors "yes" ./$*.sh
+ # || echo ignoring error
+
+endif