summaryrefslogtreecommitdiffstats
path: root/examples/librbd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/librbd/Makefile')
-rw-r--r--examples/librbd/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/examples/librbd/Makefile b/examples/librbd/Makefile
new file mode 100644
index 000000000..2cd9f269a
--- /dev/null
+++ b/examples/librbd/Makefile
@@ -0,0 +1,27 @@
+
+CXX?=g++
+CXX_FLAGS?=-std=c++11 -Wno-unused-parameter -Wall -Wextra -Werror -g
+CXX_LIBS?=-lboost_system -lrbd -lrados
+CXX_INC?=$(LOCAL_LIBRADOS_INC)
+CXX_CC=$(CXX) $(CXX_FLAGS) $(CXX_INC) $(LOCAL_LIBRADOS)
+
+# Relative path to the Ceph source:
+CEPH_SRC_HOME?=../../src
+CEPH_BLD_HOME?=../../build
+
+LOCAL_LIBRADOS?=-L$(CEPH_BLD_HOME)/lib/ -Wl,-rpath,$(CEPH_BLD_HOME)/lib
+LOCAL_LIBRADOS_INC?=-I$(CEPH_SRC_HOME)/include
+
+all: hello_world_cpp
+
+# Build against the system librados instead of the one in the build tree:
+all-system: LOCAL_LIBRADOS=
+all-system: LOCAL_LIBRADOS_INC=
+all-system: all
+
+hello_world_cpp: hello_world.cc
+ $(CXX_CC) -o hello_world_cpp hello_world.cc $(CXX_LIBS)
+
+clean:
+ rm -f hello_world_cpp
+