summaryrefslogtreecommitdiffstats
path: root/src/auth/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/auth/CMakeLists.txt')
-rw-r--r--src/auth/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/auth/CMakeLists.txt b/src/auth/CMakeLists.txt
new file mode 100644
index 000000000..8e849373a
--- /dev/null
+++ b/src/auth/CMakeLists.txt
@@ -0,0 +1,24 @@
+set(auth_srcs
+ AuthClientHandler.cc
+ AuthMethodList.cc
+ AuthRegistry.cc
+ AuthSessionHandler.cc
+ Crypto.cc
+ KeyRing.cc
+ RotatingKeyRing.cc
+ cephx/CephxAuthorizeHandler.cc
+ cephx/CephxClientHandler.cc
+ cephx/CephxProtocol.cc
+ cephx/CephxSessionHandler.cc
+ none/AuthNoneAuthorizeHandler.cc)
+
+if(HAVE_GSSAPI)
+ list(APPEND auth_srcs
+ krb/KrbAuthorizeHandler.cpp
+ krb/KrbClientHandler.cpp
+ krb/KrbProtocol.cpp
+ krb/KrbSessionHandler.hpp)
+endif()
+
+add_library(common-auth-objs OBJECT ${auth_srcs})
+target_include_directories(common-auth-objs PRIVATE ${OPENSSL_INCLUDE_DIR})