summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/beast/test/example/common
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/beast/test/example/common')
-rw-r--r--src/boost/libs/beast/test/example/common/CMakeLists.txt31
-rw-r--r--src/boost/libs/beast/test/example/common/Jamfile27
-rw-r--r--src/boost/libs/beast/test/example/common/root_certificates.cpp11
-rw-r--r--src/boost/libs/beast/test/example/common/server_certificate.cpp11
4 files changed, 80 insertions, 0 deletions
diff --git a/src/boost/libs/beast/test/example/common/CMakeLists.txt b/src/boost/libs/beast/test/example/common/CMakeLists.txt
new file mode 100644
index 000000000..a2c6dfe13
--- /dev/null
+++ b/src/boost/libs/beast/test/example/common/CMakeLists.txt
@@ -0,0 +1,31 @@
+#
+# Copyright (c) 2016-2017 Vinnie Falco (vinnie dot falco at gmail dot com)
+#
+# Distributed under the Boost Software License, Version 1.0. (See accompanying
+# file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+#
+# Official repository: https://github.com/boostorg/beast
+#
+
+GroupSources (include/boost/beast beast)
+GroupSources (example/common common)
+GroupSources (test/extras/include/boost/beast extras)
+GroupSources (test/example/common "/")
+
+add_executable (tests-example-common
+ ${BOOST_BEAST_FILES}
+ ${COMMON_FILES}
+ ${EXTRAS_FILES}
+ Jamfile
+ root_certificates.cpp
+ server_certificate.cpp
+)
+
+target_link_libraries(tests-example-common
+ lib-asio
+ lib-asio-ssl
+ lib-beast
+ lib-test
+ )
+
+set_property(TARGET tests-example-common PROPERTY FOLDER "tests") \ No newline at end of file
diff --git a/src/boost/libs/beast/test/example/common/Jamfile b/src/boost/libs/beast/test/example/common/Jamfile
new file mode 100644
index 000000000..6ae40e513
--- /dev/null
+++ b/src/boost/libs/beast/test/example/common/Jamfile
@@ -0,0 +1,27 @@
+#
+# Copyright (c) 2016-2017 Vinnie Falco (vinnie dot falco at gmail dot com)
+#
+# Distributed under the Boost Software License, Version 1.0. (See accompanying
+# file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+#
+# Official repository: https://github.com/boostorg/beast
+#
+
+local SOURCES =
+ root_certificates.cpp
+ server_certificate.cpp
+ ;
+
+local RUN_TESTS ;
+
+local libs =
+ /boost/beast//lib-asio-ssl
+ /boost/beast/test//lib-test
+ ;
+
+for local f in $(SOURCES)
+{
+ RUN_TESTS += [ run $(f) $(libs) ] ;
+}
+
+alias run-tests : $(RUN_TESTS) ;
diff --git a/src/boost/libs/beast/test/example/common/root_certificates.cpp b/src/boost/libs/beast/test/example/common/root_certificates.cpp
new file mode 100644
index 000000000..780d5ed66
--- /dev/null
+++ b/src/boost/libs/beast/test/example/common/root_certificates.cpp
@@ -0,0 +1,11 @@
+//
+// Copyright (c) 2016-2019 Vinnie Falco (vinnie dot falco at gmail dot com)
+//
+// Distributed under the Boost Software License, Version 1.0. (See accompanying
+// file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+//
+// Official repository: https://github.com/boostorg/beast
+//
+
+// Test that header file is self-contained.
+#include "example/common/root_certificates.hpp"
diff --git a/src/boost/libs/beast/test/example/common/server_certificate.cpp b/src/boost/libs/beast/test/example/common/server_certificate.cpp
new file mode 100644
index 000000000..ffb349337
--- /dev/null
+++ b/src/boost/libs/beast/test/example/common/server_certificate.cpp
@@ -0,0 +1,11 @@
+//
+// Copyright (c) 2016-2019 Vinnie Falco (vinnie dot falco at gmail dot com)
+//
+// Distributed under the Boost Software License, Version 1.0. (See accompanying
+// file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+//
+// Official repository: https://github.com/boostorg/beast
+//
+
+// Test that header file is self-contained.
+#include "example/common/server_certificate.hpp"