summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/fusion/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/fusion/CMakeLists.txt')
-rw-r--r--src/boost/libs/fusion/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/boost/libs/fusion/CMakeLists.txt b/src/boost/libs/fusion/CMakeLists.txt
new file mode 100644
index 000000000..2972717b1
--- /dev/null
+++ b/src/boost/libs/fusion/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Copyright 2018 Mike Dev
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at https://www.boost.org/LICENSE_1_0.txt
+#
+# Partial (add_subdirectory only) and experimental CMake support
+# Subject to change; please do not rely on the contents of this file yet
+
+cmake_minimum_required(VERSION 3.5)
+project(BoostFusion LANGUAGES CXX)
+
+add_library(boost_fusion INTERFACE)
+add_library(Boost::fusion ALIAS boost_fusion)
+
+target_include_directories(boost_fusion INTERFACE include)
+
+target_link_libraries(boost_fusion
+ INTERFACE
+ Boost::config
+ Boost::container_hash
+ Boost::core
+ Boost::function_types
+ Boost::mpl
+ Boost::preprocessor
+ Boost::static_assert
+ Boost::tuple
+ Boost::type_traits
+ Boost::typeof
+ Boost::utility
+)