summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/hana/example/cmake_integration
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/hana/example/cmake_integration')
-rw-r--r--src/boost/libs/hana/example/cmake_integration/CMakeLists.txt12
-rw-r--r--src/boost/libs/hana/example/cmake_integration/main.cpp8
2 files changed, 20 insertions, 0 deletions
diff --git a/src/boost/libs/hana/example/cmake_integration/CMakeLists.txt b/src/boost/libs/hana/example/cmake_integration/CMakeLists.txt
new file mode 100644
index 000000000..000d03dd8
--- /dev/null
+++ b/src/boost/libs/hana/example/cmake_integration/CMakeLists.txt
@@ -0,0 +1,12 @@
+# Copyright Louis Dionne 2013-2017
+# Distributed under the Boost Software License, Version 1.0.
+# (See accompanying file LICENSE.md or copy at http://boost.org/LICENSE_1_0.txt)
+
+# [snip]
+cmake_minimum_required(VERSION 3.0)
+project(external CXX)
+
+find_package(Hana REQUIRED)
+add_executable(external main.cpp)
+target_link_libraries(external hana)
+# [snip]
diff --git a/src/boost/libs/hana/example/cmake_integration/main.cpp b/src/boost/libs/hana/example/cmake_integration/main.cpp
new file mode 100644
index 000000000..e35e81350
--- /dev/null
+++ b/src/boost/libs/hana/example/cmake_integration/main.cpp
@@ -0,0 +1,8 @@
+// Copyright Louis Dionne 2013-2017
+// Distributed under the Boost Software License, Version 1.0.
+// (See accompanying file LICENSE.md or copy at http://boost.org/LICENSE_1_0.txt)
+
+#include <boost/hana.hpp>
+
+
+int main() { }