summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/move/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/move/CMakeLists.txt')
-rw-r--r--src/boost/libs/move/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/boost/libs/move/CMakeLists.txt b/src/boost/libs/move/CMakeLists.txt
new file mode 100644
index 000000000..f68503a98
--- /dev/null
+++ b/src/boost/libs/move/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Copyright 2018 Mike Dev
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt
+#
+# NOTE: CMake support for Boost.Move is currently experimental at best
+# and the interface is likely to change in the future
+
+cmake_minimum_required(VERSION 3.5)
+project(BoostMove LANGUAGES CXX)
+
+add_library(boost_move INTERFACE)
+add_library(Boost::move ALIAS boost_move)
+
+target_include_directories(boost_move INTERFACE include)
+
+target_link_libraries(boost_move
+ INTERFACE
+ Boost::assert
+ Boost::config
+ Boost::core
+ Boost::static_assert
+)
+