summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/mpl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/mpl/CMakeLists.txt')
-rw-r--r--src/boost/libs/mpl/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/boost/libs/mpl/CMakeLists.txt b/src/boost/libs/mpl/CMakeLists.txt
new file mode 100644
index 000000000..2d6020a39
--- /dev/null
+++ b/src/boost/libs/mpl/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Copyright 2018 Mike Dev
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at https://www.boost.org/LICENSE_1_0.txt
+#
+# NOTE: CMake support for Boost.Mpl is currently experimental at best
+# and the interface is likely to change in the future
+
+cmake_minimum_required( VERSION 3.5 )
+project( BoostMpl LANGUAGES CXX )
+
+add_library( boost_mpl INTERFACE )
+add_library( Boost::mpl ALIAS boost_mpl )
+
+target_include_directories( boost_mpl INTERFACE include )
+
+target_link_libraries( boost_mpl
+ INTERFACE
+ Boost::config
+ Boost::core
+ Boost::predef
+ Boost::preprocessor
+ Boost::static_assert
+ Boost::type_traits
+ Boost::utility
+)
+