summaryrefslogtreecommitdiffstats
path: root/src/civetweb/examples/_obsolete/websocket_client/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/civetweb/examples/_obsolete/websocket_client/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/civetweb/examples/_obsolete/websocket_client/Makefile b/src/civetweb/examples/_obsolete/websocket_client/Makefile
new file mode 100644
index 000000000..e3ef13468
--- /dev/null
+++ b/src/civetweb/examples/_obsolete/websocket_client/Makefile
@@ -0,0 +1,37 @@
+#
+# Copyright (c) 2014 Jordan Shelley
+# https://github.com/jshelley
+# License http://opensource.org/licenses/mit-license.php MIT License
+#
+
+#This makefile is used to test the other Makefiles
+
+
+PROG = websocket_client
+SRC = websocket_client.c
+
+TOP = ../..
+CIVETWEB_LIB = libcivetweb.a
+
+CFLAGS = -I$(TOP)/include $(COPT)
+LIBS = -lpthread
+
+include $(TOP)/resources/Makefile.in-os
+
+ifeq ($(TARGET_OS),LINUX)
+ LIBS += -ldl
+endif
+
+all: $(PROG)
+
+$(PROG): $(CIVETWEB_LIB) $(SRC)
+ $(CC) -o $@ $(CFLAGS) $(LDFLAGS) $(SRC) $(CIVETWEB_LIB) $(LIBS)
+
+$(CIVETWEB_LIB):
+ $(MAKE) -C $(TOP) clean lib WITH_WEBSOCKET=1
+ cp $(TOP)/$(CIVETWEB_LIB) .
+
+clean:
+ rm -f $(CIVETWEB_LIB) $(PROG)
+
+.PHONY: all clean