summaryrefslogtreecommitdiffstats
path: root/src/civetweb/resources/Makefile.in-os
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/civetweb/resources/Makefile.in-os23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/civetweb/resources/Makefile.in-os b/src/civetweb/resources/Makefile.in-os
new file mode 100644
index 000000000..a75913486
--- /dev/null
+++ b/src/civetweb/resources/Makefile.in-os
@@ -0,0 +1,23 @@
+#
+# Copyright (c) 2013 No Face Press, LLC
+# License http://opensource.org/licenses/mit-license.php MIT License
+#
+
+# Override this using TARGET_OS=LINUX on the command line
+ifeq ($(TARGET_OS),)
+ ifeq ($(OS),Windows_NT)
+ TARGET_OS = WIN32
+ else
+ UNAME_S := $(shell uname -s)
+ ifeq ($(UNAME_S),Linux)
+ TARGET_OS = LINUX
+ else
+ ifeq ($(UNAME_S),Darwin)
+ TARGET_OS = OSX
+ else
+ TARGET_OS = BSD
+ endif
+ endif
+ endif
+endif
+