summaryrefslogtreecommitdiffstats
path: root/src/compressor/snappy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/compressor/snappy/CMakeLists.txt')
-rw-r--r--src/compressor/snappy/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/compressor/snappy/CMakeLists.txt b/src/compressor/snappy/CMakeLists.txt
new file mode 100644
index 000000000..d1ba3b2e7
--- /dev/null
+++ b/src/compressor/snappy/CMakeLists.txt
@@ -0,0 +1,14 @@
+# snappy
+
+set(snappy_sources
+ CompressionPluginSnappy.cc
+)
+
+add_library(ceph_snappy SHARED ${snappy_sources})
+target_link_libraries(ceph_snappy
+ PRIVATE snappy::snappy compressor $<$<PLATFORM_ID:Windows>:ceph-common>)
+set_target_properties(ceph_snappy PROPERTIES
+ VERSION 2.0.0
+ SOVERSION 2
+ INSTALL_RPATH "")
+install(TARGETS ceph_snappy DESTINATION ${compressor_plugin_dir})