summaryrefslogtreecommitdiffstats
path: root/src/dokan/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/dokan/CMakeLists.txt')
-rw-r--r--src/dokan/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/dokan/CMakeLists.txt b/src/dokan/CMakeLists.txt
new file mode 100644
index 000000000..cc05a0f29
--- /dev/null
+++ b/src/dokan/CMakeLists.txt
@@ -0,0 +1,12 @@
+set(ceph_dokan_srcs
+ ceph_dokan.cc
+ dbg.cc
+ utils.cc
+ options.cc)
+add_executable(ceph-dokan ${ceph_dokan_srcs})
+target_link_libraries(ceph-dokan ${DOKAN_LIBRARIES}
+ ${GSSAPI_LIBRARIES}
+ cephfs ceph-common global ${EXTRALIBS})
+set_target_properties(ceph-dokan PROPERTIES
+ COMPILE_FLAGS "-I${DOKAN_INCLUDE_DIRS}")
+install(TARGETS ceph-dokan DESTINATION bin)