summaryrefslogtreecommitdiffstats
path: root/src/erasure-code/jerasure/gf-complete/examples
diff options
context:
space:
mode:
Diffstat (limited to 'src/erasure-code/jerasure/gf-complete/examples')
-rw-r--r--src/erasure-code/jerasure/gf-complete/examples/Makefile.am37
-rw-r--r--src/erasure-code/jerasure/gf-complete/examples/gf_example_1.c58
-rw-r--r--src/erasure-code/jerasure/gf-complete/examples/gf_example_2.c107
-rw-r--r--src/erasure-code/jerasure/gf-complete/examples/gf_example_3.c74
-rw-r--r--src/erasure-code/jerasure/gf-complete/examples/gf_example_4.c69
-rw-r--r--src/erasure-code/jerasure/gf-complete/examples/gf_example_5.c78
-rw-r--r--src/erasure-code/jerasure/gf-complete/examples/gf_example_6.c84
-rw-r--r--src/erasure-code/jerasure/gf-complete/examples/gf_example_7.c75
8 files changed, 582 insertions, 0 deletions
diff --git a/src/erasure-code/jerasure/gf-complete/examples/Makefile.am b/src/erasure-code/jerasure/gf-complete/examples/Makefile.am
new file mode 100644
index 000000000..a420bda84
--- /dev/null
+++ b/src/erasure-code/jerasure/gf-complete/examples/Makefile.am
@@ -0,0 +1,37 @@
+# GF-Complete 'examples' AM file
+
+AM_CPPFLAGS = -I$(top_builddir)/include -I$(top_srcdir)/include
+AM_CFLAGS = -O3 $(SIMD_FLAGS) -fPIC
+
+bin_PROGRAMS = gf_example_1 gf_example_2 gf_example_3 gf_example_4 \
+ gf_example_5 gf_example_6 gf_example_7
+
+gf_example_1_SOURCES = gf_example_1.c
+#gf_example_1_LDFLAGS = -lgf_complete
+gf_example_1_LDADD = ../src/libgf_complete.la
+
+gf_example_2_SOURCES = gf_example_2.c
+#gf_example_2_LDFLAGS = -lgf_complete
+gf_example_2_LDADD = ../src/libgf_complete.la
+
+gf_example_3_SOURCES = gf_example_3.c
+#gf_example_3_LDFLAGS = -lgf_complete
+gf_example_3_LDADD = ../src/libgf_complete.la
+
+gf_example_4_SOURCES = gf_example_4.c
+#gf_example_4_LDFLAGS = -lgf_complete
+gf_example_4_LDADD = ../src/libgf_complete.la
+
+gf_example_5_SOURCES = gf_example_5.c
+#gf_example_5_LDFLAGS = -lgf_complete
+gf_example_5_LDADD = ../src/libgf_complete.la
+
+gf_example_6_SOURCES = gf_example_6.c
+#gf_example_6_LDFLAGS = -lgf_complete
+gf_example_6_LDADD = ../src/libgf_complete.la
+
+gf_example_7_SOURCES = gf_example_7.c
+#gf_example_7_LDFLAGS = -lgf_complete
+gf_example_7_LDADD = ../src/libgf_complete.la
+
+
diff --git a/src/erasure-code/jerasure/gf-complete/examples/gf_example_1.c b/src/erasure-code/jerasure/gf-complete/examples/gf_example_1.c
new file mode 100644
index 000000000..a7a415595
--- /dev/null
+++ b/src/erasure-code/jerasure/gf-complete/examples/gf_example_1.c
@@ -0,0 +1,58 @@
+/*
+ * GF-Complete: A Comprehensive Open Source Library for Galois Field Arithmetic
+ * James S. Plank, Ethan L. Miller, Kevin M. Greenan,
+ * Benjamin A. Arnold, John A. Burnum, Adam W. Disney, Allen C. McBride.
+ *
+ * gf_example_1.c
+ *
+ * Demonstrates using the procedures for examples in GF(2^w) for w <= 32.
+ */
+
+#include <stdio.h>
+#include <getopt.h>
+#include <stdint.h>
+#include <string.h>
+#include <stdlib.h>
+#include <time.h>
+
+#include "gf_complete.h"
+#include "gf_rand.h"
+
+void usage(char *s)
+{
+ fprintf(stderr, "usage: gf_example_1 w - w must be between 1 and 32\n");
+ exit(1);
+}
+
+int main(int argc, char **argv)
+{
+ uint32_t a, b, c;
+ int w;
+ gf_t gf;
+
+ if (argc != 2) usage(NULL);
+ w = atoi(argv[1]);
+ if (w <= 0 || w > 32) usage("Bad w");
+
+ /* Get two random numbers in a and b */
+
+ MOA_Seed(time(0));
+ a = MOA_Random_W(w, 0);
+ b = MOA_Random_W(w, 0);
+
+ /* Create the proper instance of the gf_t object using defaults: */
+
+ gf_init_easy(&gf, w);
+
+ /* And multiply a and b using the galois field: */
+
+ c = gf.multiply.w32(&gf, a, b);
+ printf("%u * %u = %u\n", a, b, c);
+
+ /* Divide the product by a and b */
+
+ printf("%u / %u = %u\n", c, a, gf.divide.w32(&gf, c, a));
+ printf("%u / %u = %u\n", c, b, gf.divide.w32(&gf, c, b));
+
+ exit(0);
+}
diff --git a/src/erasure-code/jerasure/gf-complete/examples/gf_example_2.c b/src/erasure-code/jerasure/gf-complete/examples/gf_example_2.c
new file mode 100644
index 000000000..576d9a534
--- /dev/null
+++ b/src/erasure-code/jerasure/gf-complete/examples/gf_example_2.c
@@ -0,0 +1,107 @@
+/*
+ * GF-Complete: A Comprehensive Open Source Library for Galois Field Arithmetic
+ * James S. Plank, Ethan L. Miller, Kevin M. Greenan,
+ * Benjamin A. Arnold, John A. Burnum, Adam W. Disney, Allen C. McBride.
+ *
+ * gf_example_2.c
+ *
+ * Demonstrates using the procedures for examples in GF(2^w) for w <= 32.
+ */
+
+#include <stdio.h>
+#include <getopt.h>
+#include <stdint.h>
+#include <string.h>
+#include <stdlib.h>
+#include <time.h>
+
+#include "gf_complete.h"
+#include "gf_rand.h"
+
+void usage(char *s)
+{
+ fprintf(stderr, "usage: gf_example_2 w - w must be between 1 and 32\n");
+ exit(1);
+}
+
+int main(int argc, char **argv)
+{
+ uint32_t a, b, c;
+ uint8_t *r1, *r2;
+ uint16_t *r16 = NULL;
+ uint32_t *r32 = NULL;
+ int w, i;
+ gf_t gf;
+
+ if (argc != 2) usage(NULL);
+ w = atoi(argv[1]);
+ if (w <= 0 || w > 32) usage("Bad w");
+
+ /* Get two random numbers in a and b */
+
+ MOA_Seed(time(0));
+ a = MOA_Random_W(w, 0);
+ b = MOA_Random_W(w, 0);
+
+ /* Create the proper instance of the gf_t object using defaults: */
+
+ gf_init_easy(&gf, w);
+
+ /* And multiply a and b using the galois field: */
+
+ c = gf.multiply.w32(&gf, a, b);
+ printf("%u * %u = %u\n", a, b, c);
+
+ /* Divide the product by a and b */
+
+ printf("%u / %u = %u\n", c, a, gf.divide.w32(&gf, c, a));
+ printf("%u / %u = %u\n", c, b, gf.divide.w32(&gf, c, b));
+
+ /* If w is 4, 8, 16 or 32, do a very small region operation */
+
+ if (w == 4 || w == 8 || w == 16 || w == 32) {
+ r1 = (uint8_t *) malloc(16);
+ r2 = (uint8_t *) malloc(16);
+
+ if (w == 4 || w == 8) {
+ r1[0] = b;
+ for (i = 1; i < 16; i++) r1[i] = MOA_Random_W(8, 1);
+ } else if (w == 16) {
+ r16 = (uint16_t *) r1;
+ r16[0] = b;
+ for (i = 1; i < 8; i++) r16[i] = MOA_Random_W(16, 1);
+ } else {
+ r32 = (uint32_t *) r1;
+ r32[0] = b;
+ for (i = 1; i < 4; i++) r32[i] = MOA_Random_W(32, 1);
+ }
+
+ gf.multiply_region.w32(&gf, r1, r2, a, 16, 0);
+
+ printf("\nmultiply_region by 0x%x (%u)\n\n", a, a);
+ printf("R1 (the source): ");
+ if (w == 4) {
+ for (i = 0; i < 16; i++) printf(" %x %x", r1[i] >> 4, r1[i] & 0xf);
+ } else if (w == 8) {
+ for (i = 0; i < 16; i++) printf(" %02x", r1[i]);
+ } else if (w == 16) {
+ for (i = 0; i < 8; i++) printf(" %04x", r16[i]);
+ } else if (w == 32) {
+ for (i = 0; i < 4; i++) printf(" %08x", r32[i]);
+ }
+ printf("\nR2 (the product): ");
+ if (w == 4) {
+ for (i = 0; i < 16; i++) printf(" %x %x", r2[i] >> 4, r2[i] & 0xf);
+ } else if (w == 8) {
+ for (i = 0; i < 16; i++) printf(" %02x", r2[i]);
+ } else if (w == 16) {
+ r16 = (uint16_t *) r2;
+ for (i = 0; i < 8; i++) printf(" %04x", r16[i]);
+ } else if (w == 32) {
+ r32 = (uint32_t *) r2;
+ for (i = 0; i < 4; i++) printf(" %08x", r32[i]);
+ }
+ printf("\n");
+ }
+ exit(0);
+}
diff --git a/src/erasure-code/jerasure/gf-complete/examples/gf_example_3.c b/src/erasure-code/jerasure/gf-complete/examples/gf_example_3.c
new file mode 100644
index 000000000..d6fef879e
--- /dev/null
+++ b/src/erasure-code/jerasure/gf-complete/examples/gf_example_3.c
@@ -0,0 +1,74 @@
+/*
+ * GF-Complete: A Comprehensive Open Source Library for Galois Field Arithmetic
+ * James S. Plank, Ethan L. Miller, Kevin M. Greenan,
+ * Benjamin A. Arnold, John A. Burnum, Adam W. Disney, Allen C. McBride.
+ *
+ * gf_example_3.c
+ *
+ * Identical to example_2 except it works in GF(2^64)
+ */
+
+#include <stdio.h>
+#include <getopt.h>
+#include <stdint.h>
+#include <string.h>
+#include <stdlib.h>
+#include <time.h>
+
+#include "gf_complete.h"
+#include "gf_rand.h"
+
+void usage(char *s)
+{
+ fprintf(stderr, "usage: gf_example_3\n");
+ exit(1);
+}
+
+int main(int argc, char **argv)
+{
+ uint64_t a, b, c;
+ uint64_t *r1, *r2;
+ int i;
+ gf_t gf;
+
+ if (argc != 1) usage(NULL);
+
+ /* Get two random numbers in a and b */
+
+ MOA_Seed(time(0));
+ a = MOA_Random_64();
+ b = MOA_Random_64();
+
+ /* Create the proper instance of the gf_t object using defaults: */
+
+ gf_init_easy(&gf, 64);
+
+ /* And multiply a and b using the galois field: */
+
+ c = gf.multiply.w64(&gf, a, b);
+ printf("%llx * %llx = %llx\n", (long long unsigned int) a, (long long unsigned int) b, (long long unsigned int) c);
+
+ /* Divide the product by a and b */
+
+ printf("%llx / %llx = %llx\n", (long long unsigned int) c, (long long unsigned int) a, (long long unsigned int) gf.divide.w64(&gf, c, a));
+ printf("%llx / %llx = %llx\n", (long long unsigned int) c, (long long unsigned int) b, (long long unsigned int) gf.divide.w64(&gf, c, b));
+
+ r1 = (uint64_t *) malloc(32);
+ r2 = (uint64_t *) malloc(32);
+
+ r1[0] = b;
+
+ for (i = 1; i < 4; i++) r1[i] = MOA_Random_64();
+
+ gf.multiply_region.w64(&gf, r1, r2, a, 32, 0);
+
+ printf("\nmultiply_region by %llx\n\n", (long long unsigned int) a);
+ printf("R1 (the source): ");
+ for (i = 0; i < 4; i++) printf(" %016llx", (long long unsigned int) r1[i]);
+
+ printf("\nR2 (the product): ");
+ for (i = 0; i < 4; i++) printf(" %016llx", (long long unsigned int) r2[i]);
+ printf("\n");
+
+ exit(0);
+}
diff --git a/src/erasure-code/jerasure/gf-complete/examples/gf_example_4.c b/src/erasure-code/jerasure/gf-complete/examples/gf_example_4.c
new file mode 100644
index 000000000..17529b5b0
--- /dev/null
+++ b/src/erasure-code/jerasure/gf-complete/examples/gf_example_4.c
@@ -0,0 +1,69 @@
+/*
+ * GF-Complete: A Comprehensive Open Source Library for Galois Field Arithmetic
+ * James S. Plank, Ethan L. Miller, Kevin M. Greenan,
+ * Benjamin A. Arnold, John A. Burnum, Adam W. Disney, Allen C. McBride.
+ *
+ * gf_example_4.c
+ *
+ * Identical to example_3 except it works in GF(2^128)
+ */
+
+#include <stdio.h>
+#include <getopt.h>
+#include <stdint.h>
+#include <string.h>
+#include <stdlib.h>
+#include <time.h>
+
+#include "gf_complete.h"
+#include "gf_rand.h"
+
+#define LLUI (long long unsigned int)
+
+void usage(char *s)
+{
+ fprintf(stderr, "usage: gf_example_3\n");
+ exit(1);
+}
+
+int main(int argc, char **argv)
+{
+ uint64_t a[2], b[2], c[2];
+ uint64_t *r1, *r2;
+ int i;
+ gf_t gf;
+
+ if (argc != 1) usage(NULL);
+
+ /* Get two random numbers in a and b */
+
+ MOA_Seed(time(0));
+ MOA_Random_128(a);
+ MOA_Random_128(b);
+
+ /* Create the proper instance of the gf_t object using defaults: */
+
+ gf_init_easy(&gf, 128);
+
+ /* And multiply a and b using the galois field: */
+
+ gf.multiply.w128(&gf, a, b, c);
+ printf("%016llx%016llx * %016llx%016llx =\n%016llx%016llx\n",
+ LLUI a[0], LLUI a[1], LLUI b[0], LLUI b[1], LLUI c[0], LLUI c[1]);
+
+ r1 = (uint64_t *) malloc(32);
+ r2 = (uint64_t *) malloc(32);
+
+ for (i = 0; i < 4; i++) r1[i] = MOA_Random_64();
+
+ gf.multiply_region.w128(&gf, r1, r2, a, 32, 0);
+
+ printf("\nmultiply_region by %016llx%016llx\n\n", LLUI a[0], LLUI a[1]);
+ printf("R1 (the source): ");
+ for (i = 0; i < 4; i += 2) printf(" %016llx%016llx", LLUI r1[i], LLUI r1[i+1]);
+
+ printf("\nR2 (the product): ");
+ for (i = 0; i < 4; i += 2) printf(" %016llx%016llx", LLUI r2[i], LLUI r2[i+1]);
+ printf("\n");
+ exit(0);
+}
diff --git a/src/erasure-code/jerasure/gf-complete/examples/gf_example_5.c b/src/erasure-code/jerasure/gf-complete/examples/gf_example_5.c
new file mode 100644
index 000000000..da6e9ca68
--- /dev/null
+++ b/src/erasure-code/jerasure/gf-complete/examples/gf_example_5.c
@@ -0,0 +1,78 @@
+/*
+ * GF-Complete: A Comprehensive Open Source Library for Galois Field Arithmetic
+ * James S. Plank, Ethan L. Miller, Kevin M. Greenan,
+ * Benjamin A. Arnold, John A. Burnum, Adam W. Disney, Allen C. McBride.
+ *
+ * gf_example_5.c
+ *
+ * Demonstrating altmap and extract_word
+ */
+
+#include <stdio.h>
+#include <getopt.h>
+#include <stdint.h>
+#include <string.h>
+#include <stdlib.h>
+#include <time.h>
+
+#include "gf_complete.h"
+#include "gf_rand.h"
+
+void usage(char *s)
+{
+ fprintf(stderr, "usage: gf_example_5\n");
+ exit(1);
+}
+
+int main(int argc, char **argv)
+{
+ uint16_t *a, *b;
+ int i, j;
+ gf_t gf;
+
+ if (gf_init_hard(&gf, 16, GF_MULT_SPLIT_TABLE, GF_REGION_ALTMAP, GF_DIVIDE_DEFAULT,
+ 0, 16, 4, NULL, NULL) == 0) {
+ fprintf(stderr, "gf_init_hard failed\n");
+ exit(1);
+ }
+
+ a = (uint16_t *) malloc(200);
+ b = (uint16_t *) malloc(200);
+
+ a += 6;
+ b += 6;
+
+ MOA_Seed(0);
+
+ for (i = 0; i < 30; i++) a[i] = MOA_Random_W(16, 1);
+
+ gf.multiply_region.w32(&gf, a, b, 0x1234, 30*2, 0);
+
+ printf("a: 0x%lx b: 0x%lx\n", (unsigned long) a, (unsigned long) b);
+
+ for (i = 0; i < 30; i += 10) {
+ printf("\n");
+ printf(" ");
+ for (j = 0; j < 10; j++) printf(" %4d", i+j);
+ printf("\n");
+
+ printf("a:");
+ for (j = 0; j < 10; j++) printf(" %04x", a[i+j]);
+ printf("\n");
+
+ printf("b:");
+ for (j = 0; j < 10; j++) printf(" %04x", b[i+j]);
+ printf("\n");
+ printf("\n");
+ }
+
+ for (i = 0; i < 15; i ++) {
+ printf("Word %2d: 0x%04x * 0x1234 = 0x%04x ", i,
+ gf.extract_word.w32(&gf, a, 30*2, i),
+ gf.extract_word.w32(&gf, b, 30*2, i));
+ printf("Word %2d: 0x%04x * 0x1234 = 0x%04x\n", i+15,
+ gf.extract_word.w32(&gf, a, 30*2, i+15),
+ gf.extract_word.w32(&gf, b, 30*2, i+15));
+ }
+ return 0;
+}
diff --git a/src/erasure-code/jerasure/gf-complete/examples/gf_example_6.c b/src/erasure-code/jerasure/gf-complete/examples/gf_example_6.c
new file mode 100644
index 000000000..800a35ffb
--- /dev/null
+++ b/src/erasure-code/jerasure/gf-complete/examples/gf_example_6.c
@@ -0,0 +1,84 @@
+/*
+ * GF-Complete: A Comprehensive Open Source Library for Galois Field Arithmetic
+ * James S. Plank, Ethan L. Miller, Kevin M. Greenan,
+ * Benjamin A. Arnold, John A. Burnum, Adam W. Disney, Allen C. McBride.
+ *
+ * gf_example_6.c
+ *
+ * Demonstrating altmap and extract_word
+ */
+
+#include <stdio.h>
+#include <getopt.h>
+#include <stdint.h>
+#include <string.h>
+#include <stdlib.h>
+#include <time.h>
+
+#include "gf_complete.h"
+#include "gf_rand.h"
+
+void usage(char *s)
+{
+ fprintf(stderr, "usage: gf_example_6\n");
+ exit(1);
+}
+
+int main(int argc, char **argv)
+{
+ uint32_t *a, *b;
+ int i, j;
+ gf_t gf, gf_16;
+
+ if (gf_init_hard(&gf_16, 16, GF_MULT_LOG_TABLE, GF_REGION_DEFAULT, GF_DIVIDE_DEFAULT,
+ 0, 0, 0, NULL, NULL) == 0) {
+ fprintf(stderr, "gf_init_hard (6) failed\n");
+ exit(1);
+ }
+
+ if (gf_init_hard(&gf, 32, GF_MULT_COMPOSITE, GF_REGION_ALTMAP, GF_DIVIDE_DEFAULT,
+ 0, 2, 0, &gf_16, NULL) == 0) {
+ fprintf(stderr, "gf_init_hard (32) failed\n");
+ exit(1);
+ }
+
+ a = (uint32_t *) malloc(200);
+ b = (uint32_t *) malloc(200);
+
+ a += 3;
+ b += 3;
+
+ MOA_Seed(0);
+
+ for (i = 0; i < 30; i++) a[i] = MOA_Random_W(32, 1);
+
+ gf.multiply_region.w32(&gf, a, b, 0x12345678, 30*4, 0);
+
+ printf("a: 0x%lx b: 0x%lx\n", (unsigned long) a, (unsigned long) b);
+
+ for (i = 0; i < 30; i += 10) {
+ printf("\n");
+ printf(" ");
+ for (j = 0; j < 10; j++) printf(" %8d", i+j);
+ printf("\n");
+
+ printf("a:");
+ for (j = 0; j < 10; j++) printf(" %08x", a[i+j]);
+ printf("\n");
+
+ printf("b:");
+ for (j = 0; j < 10; j++) printf(" %08x", b[i+j]);
+ printf("\n");
+ printf("\n");
+ }
+
+ for (i = 0; i < 15; i ++) {
+ printf("Word %2d: 0x%08x * 0x12345678 = 0x%08x ", i,
+ gf.extract_word.w32(&gf, a, 30*4, i),
+ gf.extract_word.w32(&gf, b, 30*4, i));
+ printf("Word %2d: 0x%08x * 0x12345678 = 0x%08x\n", i+15,
+ gf.extract_word.w32(&gf, a, 30*4, i+15),
+ gf.extract_word.w32(&gf, b, 30*4, i+15));
+ }
+ return 0;
+}
diff --git a/src/erasure-code/jerasure/gf-complete/examples/gf_example_7.c b/src/erasure-code/jerasure/gf-complete/examples/gf_example_7.c
new file mode 100644
index 000000000..ee07d5353
--- /dev/null
+++ b/src/erasure-code/jerasure/gf-complete/examples/gf_example_7.c
@@ -0,0 +1,75 @@
+/*
+ * GF-Complete: A Comprehensive Open Source Library for Galois Field Arithmetic
+ * James S. Plank, Ethan L. Miller, Kevin M. Greenan,
+ * Benjamin A. Arnold, John A. Burnum, Adam W. Disney, Allen C. McBride.
+ *
+ * gf_example_7.c
+ *
+ * Demonstrating extract_word and Cauchy
+ */
+
+#include <stdio.h>
+#include <getopt.h>
+#include <stdint.h>
+#include <string.h>
+#include <stdlib.h>
+#include <time.h>
+
+#include "gf_complete.h"
+#include "gf_rand.h"
+
+void usage(char *s)
+{
+ fprintf(stderr, "usage: gf_example_7\n");
+ exit(1);
+}
+
+int main(int argc, char **argv)
+{
+ uint8_t *a, *b;
+ int i, j;
+ gf_t gf;
+
+ if (gf_init_hard(&gf, 3, GF_MULT_TABLE, GF_REGION_CAUCHY, GF_DIVIDE_DEFAULT, 0, 0, 0, NULL, NULL) == 0) {
+ fprintf(stderr, "gf_init_hard failed\n");
+ exit(1);
+ }
+
+ a = (uint8_t *) malloc(3);
+ b = (uint8_t *) malloc(3);
+
+ MOA_Seed(0);
+
+ for (i = 0; i < 3; i++) a[i] = MOA_Random_W(8, 1);
+
+ gf.multiply_region.w32(&gf, a, b, 5, 3, 0);
+
+ printf("a: 0x%lx b: 0x%lx\n", (unsigned long) a, (unsigned long) b);
+
+ printf("\n");
+ printf("a: 0x%02x 0x%02x 0x%02x\n", a[0], a[1], a[2]);
+ printf("b: 0x%02x 0x%02x 0x%02x\n", b[0], b[1], b[2]);
+ printf("\n");
+
+ printf("a bits:");
+ for (i = 0; i < 3; i++) {
+ printf(" ");
+ for (j = 7; j >= 0; j--) printf("%c", (a[i] & (1 << j)) ? '1' : '0');
+ }
+ printf("\n");
+
+ printf("b bits:");
+ for (i = 0; i < 3; i++) {
+ printf(" ");
+ for (j = 7; j >= 0; j--) printf("%c", (b[i] & (1 << j)) ? '1' : '0');
+ }
+ printf("\n");
+
+ printf("\n");
+ for (i = 0; i < 8; i++) {
+ printf("Word %2d: %d * 5 = %d\n", i,
+ gf.extract_word.w32(&gf, a, 3, i),
+ gf.extract_word.w32(&gf, b, 3, i));
+ }
+ return 0;
+}