summaryrefslogtreecommitdiffstats
path: root/src/fmt/test/find-package-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/fmt/test/find-package-test/CMakeLists.txt')
-rw-r--r--src/fmt/test/find-package-test/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/fmt/test/find-package-test/CMakeLists.txt b/src/fmt/test/find-package-test/CMakeLists.txt
new file mode 100644
index 000000000..513575570
--- /dev/null
+++ b/src/fmt/test/find-package-test/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 3.1.0)
+
+project(fmt-test)
+
+find_package(FMT REQUIRED)
+
+add_executable(library-test main.cc)
+target_link_libraries(library-test fmt::fmt)
+target_compile_options(library-test PRIVATE ${PEDANTIC_COMPILE_FLAGS})
+target_include_directories(library-test PUBLIC SYSTEM .)
+
+if (TARGET fmt::fmt-header-only)
+ add_executable(header-only-test main.cc)
+ target_link_libraries(header-only-test fmt::fmt-header-only)
+ target_compile_options(header-only-test PRIVATE ${PEDANTIC_COMPILE_FLAGS})
+ target_include_directories(header-only-test PUBLIC SYSTEM .)
+endif ()