summaryrefslogtreecommitdiffstats
path: root/src/jaegertracing/thrift/lib/dart/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/jaegertracing/thrift/lib/dart/Makefile.am')
-rw-r--r--src/jaegertracing/thrift/lib/dart/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/jaegertracing/thrift/lib/dart/Makefile.am b/src/jaegertracing/thrift/lib/dart/Makefile.am
new file mode 100644
index 000000000..373a883d6
--- /dev/null
+++ b/src/jaegertracing/thrift/lib/dart/Makefile.am
@@ -0,0 +1,39 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+all-local:
+ $(DARTPUB) get
+
+clean-local:
+ $(RM) -r .pub
+ find . -type d -name ".dart_tool" | xargs $(RM) -r
+ find . -type f -name ".packages" | xargs $(RM)
+ find . -type d -name "packages" | xargs $(RM) -r
+
+check-local: all
+
+dist-hook:
+ $(RM) -r $(distdir)/.pub
+ find $(distdir) -type d -name ".dart_tool" | xargs $(RM) -r
+ find $(distdir) -type f -name ".packages" | xargs $(RM)
+ find $(distdir) -type d -name "packages" | xargs $(RM) -r
+
+EXTRA_DIST = \
+ .analysis_options
+