summaryrefslogtreecommitdiffstats
path: root/src/jaegertracing/thrift/lib/json/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/jaegertracing/thrift/lib/json/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/jaegertracing/thrift/lib/json/Makefile.am b/src/jaegertracing/thrift/lib/json/Makefile.am
new file mode 100644
index 000000000..6c8c0ce81
--- /dev/null
+++ b/src/jaegertracing/thrift/lib/json/Makefile.am
@@ -0,0 +1,33 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+if WITH_JAVA
+# Schema validation test depends on java
+SUBDIRS = test
+endif
+
+clean-local:
+ $(RM) -r test/build/
+
+dist-hook:
+ $(RM) -r $(distdir)/test/build/
+
+EXTRA_DIST = \
+ schema.json \
+ test