summaryrefslogtreecommitdiffstats
path: root/src/jaegertracing/thrift/test/go/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/jaegertracing/thrift/test/go/Makefile.am')
-rw-r--r--src/jaegertracing/thrift/test/go/Makefile.am65
1 files changed, 65 insertions, 0 deletions
diff --git a/src/jaegertracing/thrift/test/go/Makefile.am b/src/jaegertracing/thrift/test/go/Makefile.am
new file mode 100644
index 000000000..3cf6a70ee
--- /dev/null
+++ b/src/jaegertracing/thrift/test/go/Makefile.am
@@ -0,0 +1,65 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+BUILT_SOURCES = gopath
+
+THRIFTCMD = $(THRIFT) -out src/gen --gen go:thrift_import=thrift$(COMPILER_EXTRAFLAG)
+THRIFTTEST = $(top_srcdir)/test/ThriftTest.thrift
+
+precross: bin/testclient bin/testserver
+
+ThriftTest.thrift: $(THRIFTTEST)
+ grep -v list.*map.*list.*map $(THRIFTTEST) > ThriftTest.thrift
+
+.PHONY: gopath
+
+# Thrift for GO has problems with complex map keys: THRIFT-2063
+gopath: $(THRIFT) ThriftTest.thrift
+ mkdir -p src/gen
+ $(THRIFTCMD) ThriftTest.thrift
+ $(THRIFTCMD) ../StressTest.thrift
+ GOPATH=`pwd` $(GO) get github.com/golang/mock/gomock || true
+ sed -i 's/\"context\"/\"golang.org\/x\/net\/context\"/g' src/github.com/golang/mock/gomock/controller.go || true
+ GOPATH=`pwd` $(GO) get github.com/golang/mock/gomock
+ ln -nfs ../../../lib/go/thrift src/thrift
+ touch gopath
+
+bin/testclient: gopath
+ GOPATH=`pwd` $(GO) install bin/testclient
+
+bin/testserver: gopath
+ GOPATH=`pwd` $(GO) install bin/testserver
+
+bin/stress: gopath
+ GOPATH=`pwd` $(GO) install bin/stress
+
+clean-local:
+ $(RM) -r src/gen src/github.com/golang src/thrift bin pkg gopath ThriftTest.thrift
+
+check_PROGRAMS: bin/testclient bin/testserver bin/stress
+
+check: gopath genmock
+ GOPATH=`pwd` $(GO) test -v common/...
+
+genmock: gopath
+ sh genmock.sh
+
+EXTRA_DIST = \
+ src/bin \
+ src/common