summaryrefslogtreecommitdiffstats
path: root/src/jaegertracing/thrift/test/ocaml/server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/jaegertracing/thrift/test/ocaml/server/Makefile')
-rw-r--r--src/jaegertracing/thrift/test/ocaml/server/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/jaegertracing/thrift/test/ocaml/server/Makefile b/src/jaegertracing/thrift/test/ocaml/server/Makefile
new file mode 100644
index 000000000..44dcac761
--- /dev/null
+++ b/src/jaegertracing/thrift/test/ocaml/server/Makefile
@@ -0,0 +1,27 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+SOURCES = ../gen-ocaml/ThriftTest_types.ml ../gen-ocaml/ThriftTest_consts.ml ../gen-ocaml/SecondService.ml ../gen-ocaml/ThriftTest.ml TestServer.ml
+RESULT = ts
+INCDIRS = "../../../lib/ocaml/src/" "../gen-ocaml/"
+LIBS = thrift
+THREADS = yes
+all: nc
+OCAMLMAKEFILE = ../../../lib/ocaml/OCamlMakefile
+include $(OCAMLMAKEFILE)