summaryrefslogtreecommitdiffstats
path: root/src/jaegertracing/thrift/tutorial/java
diff options
context:
space:
mode:
Diffstat (limited to 'src/jaegertracing/thrift/tutorial/java')
-rwxr-xr-xsrc/jaegertracing/thrift/tutorial/java/Makefile.am45
-rw-r--r--src/jaegertracing/thrift/tutorial/java/README.md24
-rw-r--r--src/jaegertracing/thrift/tutorial/java/build.xml115
-rw-r--r--src/jaegertracing/thrift/tutorial/java/src/CalculatorHandler.java92
-rw-r--r--src/jaegertracing/thrift/tutorial/java/src/JavaClient.java106
-rw-r--r--src/jaegertracing/thrift/tutorial/java/src/JavaServer.java110
6 files changed, 492 insertions, 0 deletions
diff --git a/src/jaegertracing/thrift/tutorial/java/Makefile.am b/src/jaegertracing/thrift/tutorial/java/Makefile.am
new file mode 100755
index 000000000..95908b154
--- /dev/null
+++ b/src/jaegertracing/thrift/tutorial/java/Makefile.am
@@ -0,0 +1,45 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+export CLASSPATH
+
+# Make sure this doesn't fail if ant is not configured.
+clean-local:
+ ANT=$(ANT) ; if test -z "$$ANT" ; then ANT=: ; fi ; \
+ $$ANT $(ANT_FLAGS) clean
+
+all-local:
+ $(ANT) $(ANT_FLAGS) compile
+
+check-local: all
+ $(ANT) $(ANT_FLAGS) test
+
+tutorial: all
+ $(ANT) $(ANT_FLAGS) tutorial
+
+tutorialserver: all
+ $(ANT) $(ANT_FLAGS) tutorialserver
+
+tutorialclient: all
+ $(ANT) $(ANT_FLAGS) tutorialclient
+
+EXTRA_DIST = \
+ build.xml \
+ src \
+ README.md
diff --git a/src/jaegertracing/thrift/tutorial/java/README.md b/src/jaegertracing/thrift/tutorial/java/README.md
new file mode 100644
index 000000000..f109fea4a
--- /dev/null
+++ b/src/jaegertracing/thrift/tutorial/java/README.md
@@ -0,0 +1,24 @@
+Thrift Java Tutorial
+==================================================
+1) Compile the Java library
+
+ thrift/lib/java$ make
+or:
+
+ thrift/lib/java$ ant
+
+4) Run the tutorial:
+
+start server and client with one step:
+
+ thrift/tutorial/java$ make tutorial
+
+or:
+
+ thrift/tutorial/java$ make tutorialserver
+ thrift/tutorial/java$ make tutorialclient
+
+or:
+
+ thrift/tutorial/java$ ant tutorialserver
+ thrift/tutorial/java$ ant tutorialclient
diff --git a/src/jaegertracing/thrift/tutorial/java/build.xml b/src/jaegertracing/thrift/tutorial/java/build.xml
new file mode 100644
index 000000000..55cdb8fab
--- /dev/null
+++ b/src/jaegertracing/thrift/tutorial/java/build.xml
@@ -0,0 +1,115 @@
+<!--
+ Licensed to the Apache Software Foundation (ASF) under one
+ or more contributor license agreements. See the NOTICE file
+ distributed with this work for additional information
+ regarding copyright ownership. The ASF licenses this file
+ to you under the Apache License, Version 2.0 (the
+ "License"); you may not use this file except in compliance
+ with the License. You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing,
+ software distributed under the License is distributed on an
+ "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ KIND, either express or implied. See the License for the
+ specific language governing permissions and limitations
+ under the License.
+-->
+<project name="tutorial" default="tutorial" basedir=".">
+
+ <description>Thrift Java Tutorial</description>
+
+ <property name="src" location="src" />
+ <property name="gen" location="gen-java" />
+ <property name="build" location="build" />
+
+ <path id="libs.classpath">
+ <fileset dir="../../lib/java/build/libs">
+ <include name="libthrift*.jar" />
+ <exclude name="libthrift*test.jar" />
+ <exclude name="libthrift*javadoc.jar" />
+ <exclude name="libthrift*sources.jar" />
+ </fileset>
+ <fileset dir="../../lib/java/build/deps">
+ <include name="*.jar" />
+ </fileset>
+ </path>
+ <path id="build.classpath">
+ <path refid="libs.classpath" />
+ <pathelement path="${gen}" />
+ </path>
+ <path id="tutorial.classpath">
+ <path refid="build.classpath" />
+ <pathelement path="${build}" />
+ <pathelement path="tutorial.jar" />
+ </path>
+
+ <target name="init">
+ <tstamp />
+ <mkdir dir="${build}"/>
+ <mkdir dir="${build}/log"/>
+ </target>
+
+ <target name="compile" depends="init, generate">
+ <javac compiler="modern" includeantruntime="false" srcdir="${gen}" destdir="${build}" classpathref="libs.classpath" />
+ <javac compiler="modern" includeantruntime="false" srcdir="${src}" destdir="${build}" classpathref="build.classpath" />
+ </target>
+
+ <target name="test" depends="tutorial" />
+
+ <target name="tutorial" description="Run the tutorial" depends="compile">
+ <jar jarfile="tutorial.jar" basedir="${build}"/>
+ <parallel>
+ <java classname="JavaServer" fork="true" timeout="10000"
+ classpathref="tutorial.classpath" failonerror="false" output="${build}/log/tutorial.log">
+ </java>
+ <sequential>
+ <sleep seconds="2"/>
+ <echo>tutorial client simple:</echo>
+ <java classname="JavaClient"
+ classpathref="tutorial.classpath" failonerror="true">
+ <arg line="simple"/>
+ </java>
+ <echo>tutorial client secure:</echo>
+ <java classname="JavaClient"
+ classpathref="tutorial.classpath" failonerror="true">
+ <arg line="secure"/>
+ </java>
+ </sequential>
+ </parallel>
+ </target>
+
+ <target name="generate">
+ <!-- Generate the thrift gen-java source -->
+ <exec executable="../../compiler/cpp/thrift" failonerror="true">
+ <arg line="--gen java -r ../tutorial.thrift"/>
+ </exec>
+ </target>
+
+ <target name="tutorialclient" description="Run a tutorial client" depends="compile">
+ <echo>tutorial client simple:</echo>
+ <java classname="JavaClient"
+ classpathref="tutorial.classpath" failonerror="true">
+ <arg line="simple"/>
+ </java>
+ <echo>tutorial client secure:</echo>
+ <java classname="JavaClient"
+ classpathref="tutorial.classpath" failonerror="true">
+ <arg line="secure"/>
+ </java>
+ </target>
+
+ <target name="tutorialserver" description="Run a tutorial server" depends="compile">
+ <java classname="JavaServer" fork="true"
+ classpathref="tutorial.classpath" failonerror="false" output="${build}/log/tutorial.log">
+ </java>
+ </target>
+
+ <target name="clean">
+ <delete dir="${build}" />
+ <delete dir="${gen}"/>
+ <delete file="tutorial.jar" />
+ </target>
+
+</project>
diff --git a/src/jaegertracing/thrift/tutorial/java/src/CalculatorHandler.java b/src/jaegertracing/thrift/tutorial/java/src/CalculatorHandler.java
new file mode 100644
index 000000000..92944b07f
--- /dev/null
+++ b/src/jaegertracing/thrift/tutorial/java/src/CalculatorHandler.java
@@ -0,0 +1,92 @@
+/*
+ * Licensed to the Apache Software Foundation (ASF) under one
+ * or more contributor license agreements. See the NOTICE file
+ * distributed with this work for additional information
+ * regarding copyright ownership. The ASF licenses this file
+ * to you under the Apache License, Version 2.0 (the
+ * "License"); you may not use this file except in compliance
+ * with the License. You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing,
+ * software distributed under the License is distributed on an
+ * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ * KIND, either express or implied. See the License for the
+ * specific language governing permissions and limitations
+ * under the License.
+ */
+
+import org.apache.thrift.TException;
+
+// Generated code
+import tutorial.*;
+import shared.*;
+
+import java.util.HashMap;
+
+public class CalculatorHandler implements Calculator.Iface {
+
+ private HashMap<Integer,SharedStruct> log;
+
+ public CalculatorHandler() {
+ log = new HashMap<Integer, SharedStruct>();
+ }
+
+ public void ping() {
+ System.out.println("ping()");
+ }
+
+ public int add(int n1, int n2) {
+ System.out.println("add(" + n1 + "," + n2 + ")");
+ return n1 + n2;
+ }
+
+ public int calculate(int logid, Work work) throws InvalidOperation {
+ System.out.println("calculate(" + logid + ", {" + work.op + "," + work.num1 + "," + work.num2 + "})");
+ int val = 0;
+ switch (work.op) {
+ case ADD:
+ val = work.num1 + work.num2;
+ break;
+ case SUBTRACT:
+ val = work.num1 - work.num2;
+ break;
+ case MULTIPLY:
+ val = work.num1 * work.num2;
+ break;
+ case DIVIDE:
+ if (work.num2 == 0) {
+ InvalidOperation io = new InvalidOperation();
+ io.whatOp = work.op.getValue();
+ io.why = "Cannot divide by 0";
+ throw io;
+ }
+ val = work.num1 / work.num2;
+ break;
+ default:
+ InvalidOperation io = new InvalidOperation();
+ io.whatOp = work.op.getValue();
+ io.why = "Unknown operation";
+ throw io;
+ }
+
+ SharedStruct entry = new SharedStruct();
+ entry.key = logid;
+ entry.value = Integer.toString(val);
+ log.put(logid, entry);
+
+ return val;
+ }
+
+ public SharedStruct getStruct(int key) {
+ System.out.println("getStruct(" + key + ")");
+ return log.get(key);
+ }
+
+ public void zip() {
+ System.out.println("zip()");
+ }
+
+}
+
diff --git a/src/jaegertracing/thrift/tutorial/java/src/JavaClient.java b/src/jaegertracing/thrift/tutorial/java/src/JavaClient.java
new file mode 100644
index 000000000..2e35d412a
--- /dev/null
+++ b/src/jaegertracing/thrift/tutorial/java/src/JavaClient.java
@@ -0,0 +1,106 @@
+/*
+ * Licensed to the Apache Software Foundation (ASF) under one
+ * or more contributor license agreements. See the NOTICE file
+ * distributed with this work for additional information
+ * regarding copyright ownership. The ASF licenses this file
+ * to you under the Apache License, Version 2.0 (the
+ * "License"); you may not use this file except in compliance
+ * with the License. You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing,
+ * software distributed under the License is distributed on an
+ * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ * KIND, either express or implied. See the License for the
+ * specific language governing permissions and limitations
+ * under the License.
+ */
+
+// Generated code
+import tutorial.*;
+import shared.*;
+
+import org.apache.thrift.TException;
+import org.apache.thrift.transport.TSSLTransportFactory;
+import org.apache.thrift.transport.TTransport;
+import org.apache.thrift.transport.TSocket;
+import org.apache.thrift.transport.TSSLTransportFactory.TSSLTransportParameters;
+import org.apache.thrift.protocol.TBinaryProtocol;
+import org.apache.thrift.protocol.TProtocol;
+
+public class JavaClient {
+ public static void main(String [] args) {
+
+ if (args.length != 1) {
+ System.out.println("Please enter 'simple' or 'secure'");
+ System.exit(0);
+ }
+
+ try {
+ TTransport transport;
+ if (args[0].contains("simple")) {
+ transport = new TSocket("localhost", 9090);
+ transport.open();
+ }
+ else {
+ /*
+ * Similar to the server, you can use the parameters to setup client parameters or
+ * use the default settings. On the client side, you will need a TrustStore which
+ * contains the trusted certificate along with the public key.
+ * For this example it's a self-signed cert.
+ */
+ TSSLTransportParameters params = new TSSLTransportParameters();
+ params.setTrustStore("../../lib/java/test/.truststore", "thrift", "SunX509", "JKS");
+ /*
+ * Get a client transport instead of a server transport. The connection is opened on
+ * invocation of the factory method, no need to specifically call open()
+ */
+ transport = TSSLTransportFactory.getClientSocket("localhost", 9091, 0, params);
+ }
+
+ TProtocol protocol = new TBinaryProtocol(transport);
+ Calculator.Client client = new Calculator.Client(protocol);
+
+ perform(client);
+
+ transport.close();
+ } catch (TException x) {
+ x.printStackTrace();
+ }
+ }
+
+ private static void perform(Calculator.Client client) throws TException
+ {
+ client.ping();
+ System.out.println("ping()");
+
+ int sum = client.add(1,1);
+ System.out.println("1+1=" + sum);
+
+ Work work = new Work();
+
+ work.op = Operation.DIVIDE;
+ work.num1 = 1;
+ work.num2 = 0;
+ try {
+ int quotient = client.calculate(1, work);
+ System.out.println("Whoa we can divide by 0");
+ } catch (InvalidOperation io) {
+ System.out.println("Invalid operation: " + io.why);
+ }
+
+ work.op = Operation.SUBTRACT;
+ work.num1 = 15;
+ work.num2 = 10;
+ try {
+ int diff = client.calculate(1, work);
+ System.out.println("15-10=" + diff);
+ } catch (InvalidOperation io) {
+ System.out.println("Invalid operation: " + io.why);
+ }
+
+ SharedStruct log = client.getStruct(1);
+ System.out.println("Check log: " + log.value);
+ }
+}
diff --git a/src/jaegertracing/thrift/tutorial/java/src/JavaServer.java b/src/jaegertracing/thrift/tutorial/java/src/JavaServer.java
new file mode 100644
index 000000000..788473a8d
--- /dev/null
+++ b/src/jaegertracing/thrift/tutorial/java/src/JavaServer.java
@@ -0,0 +1,110 @@
+/*
+ * Licensed to the Apache Software Foundation (ASF) under one
+ * or more contributor license agreements. See the NOTICE file
+ * distributed with this work for additional information
+ * regarding copyright ownership. The ASF licenses this file
+ * to you under the Apache License, Version 2.0 (the
+ * "License"); you may not use this file except in compliance
+ * with the License. You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing,
+ * software distributed under the License is distributed on an
+ * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ * KIND, either express or implied. See the License for the
+ * specific language governing permissions and limitations
+ * under the License.
+ */
+
+import org.apache.thrift.server.TServer;
+import org.apache.thrift.server.TServer.Args;
+import org.apache.thrift.server.TSimpleServer;
+import org.apache.thrift.server.TThreadPoolServer;
+import org.apache.thrift.transport.TSSLTransportFactory;
+import org.apache.thrift.transport.TServerSocket;
+import org.apache.thrift.transport.TServerTransport;
+import org.apache.thrift.transport.TSSLTransportFactory.TSSLTransportParameters;
+
+// Generated code
+import tutorial.*;
+import shared.*;
+
+import java.util.HashMap;
+
+public class JavaServer {
+
+ public static CalculatorHandler handler;
+
+ public static Calculator.Processor processor;
+
+ public static void main(String [] args) {
+ try {
+ handler = new CalculatorHandler();
+ processor = new Calculator.Processor(handler);
+
+ Runnable simple = new Runnable() {
+ public void run() {
+ simple(processor);
+ }
+ };
+ Runnable secure = new Runnable() {
+ public void run() {
+ secure(processor);
+ }
+ };
+
+ new Thread(simple).start();
+ new Thread(secure).start();
+ } catch (Exception x) {
+ x.printStackTrace();
+ }
+ }
+
+ public static void simple(Calculator.Processor processor) {
+ try {
+ TServerTransport serverTransport = new TServerSocket(9090);
+ TServer server = new TSimpleServer(new Args(serverTransport).processor(processor));
+
+ // Use this for a multithreaded server
+ // TServer server = new TThreadPoolServer(new TThreadPoolServer.Args(serverTransport).processor(processor));
+
+ System.out.println("Starting the simple server...");
+ server.serve();
+ } catch (Exception e) {
+ e.printStackTrace();
+ }
+ }
+
+ public static void secure(Calculator.Processor processor) {
+ try {
+ /*
+ * Use TSSLTransportParameters to setup the required SSL parameters. In this example
+ * we are setting the keystore and the keystore password. Other things like algorithms,
+ * cipher suites, client auth etc can be set.
+ */
+ TSSLTransportParameters params = new TSSLTransportParameters();
+ // The Keystore contains the private key
+ params.setKeyStore("../../lib/java/test/.keystore", "thrift", null, null);
+
+ /*
+ * Use any of the TSSLTransportFactory to get a server transport with the appropriate
+ * SSL configuration. You can use the default settings if properties are set in the command line.
+ * Ex: -Djavax.net.ssl.keyStore=.keystore and -Djavax.net.ssl.keyStorePassword=thrift
+ *
+ * Note: You need not explicitly call open(). The underlying server socket is bound on return
+ * from the factory class.
+ */
+ TServerTransport serverTransport = TSSLTransportFactory.getServerSocket(9091, 0, null, params);
+ TServer server = new TSimpleServer(new Args(serverTransport).processor(processor));
+
+ // Use this for a multi threaded server
+ // TServer server = new TThreadPoolServer(new TThreadPoolServer.Args(serverTransport).processor(processor));
+
+ System.out.println("Starting the secure server...");
+ server.serve();
+ } catch (Exception e) {
+ e.printStackTrace();
+ }
+ }
+}