summaryrefslogtreecommitdiffstats
path: root/src/jaegertracing/thrift/tutorial/py.tornado
diff options
context:
space:
mode:
Diffstat (limited to 'src/jaegertracing/thrift/tutorial/py.tornado')
-rwxr-xr-xsrc/jaegertracing/thrift/tutorial/py.tornado/Makefile.am36
-rwxr-xr-xsrc/jaegertracing/thrift/tutorial/py.tornado/PythonClient.py108
-rwxr-xr-xsrc/jaegertracing/thrift/tutorial/py.tornado/PythonServer.py100
3 files changed, 244 insertions, 0 deletions
diff --git a/src/jaegertracing/thrift/tutorial/py.tornado/Makefile.am b/src/jaegertracing/thrift/tutorial/py.tornado/Makefile.am
new file mode 100755
index 000000000..4b73c1e72
--- /dev/null
+++ b/src/jaegertracing/thrift/tutorial/py.tornado/Makefile.am
@@ -0,0 +1,36 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+gen-py.tornado/tutorial/Calculator.py gen-py.tornado/shared/SharedService.py: $(top_srcdir)/tutorial/tutorial.thrift
+ $(THRIFT) --gen py:tornado -r $<
+
+all-local: gen-py.tornado/tutorial/Calculator.py
+
+tutorialserver: all
+ ${PYTHON} PythonServer.py
+
+tutorialclient: all
+ ${PYTHON} PythonClient.py
+
+clean-local:
+ $(RM) -r gen-*
+
+EXTRA_DIST = \
+ PythonServer.py \
+ PythonClient.py
diff --git a/src/jaegertracing/thrift/tutorial/py.tornado/PythonClient.py b/src/jaegertracing/thrift/tutorial/py.tornado/PythonClient.py
new file mode 100755
index 000000000..426146fc9
--- /dev/null
+++ b/src/jaegertracing/thrift/tutorial/py.tornado/PythonClient.py
@@ -0,0 +1,108 @@
+#!/usr/bin/env python
+
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+import glob
+import logging
+import sys
+
+sys.path.append('gen-py.tornado')
+sys.path.insert(0, glob.glob('../../lib/py/build/lib*')[0])
+
+from tutorial import Calculator
+from tutorial.ttypes import Operation, Work, InvalidOperation
+
+from thrift import TTornado
+from thrift.transport import TTransport
+from thrift.protocol import TBinaryProtocol
+
+from tornado import gen
+from tornado import ioloop
+
+
+@gen.coroutine
+def communicate():
+ # create client
+ transport = TTornado.TTornadoStreamTransport('localhost', 9090)
+ # open the transport, bail on error
+ try:
+ yield transport.open()
+ print('Transport is opened')
+ except TTransport.TTransportException as ex:
+ logging.error(ex)
+ raise gen.Return()
+
+ pfactory = TBinaryProtocol.TBinaryProtocolFactory()
+ client = Calculator.Client(transport, pfactory)
+
+ # ping
+ yield client.ping()
+ print("ping()")
+
+ # add
+ sum_ = yield client.add(1, 1)
+ print("1 + 1 = {0}".format(sum_))
+
+ # make a oneway call without a callback (schedule the write and continue
+ # without blocking)
+ client.zip()
+ print("zip() without callback")
+
+ # make a oneway call with a callback (we'll wait for the stream write to
+ # complete before continuing)
+ client.zip()
+ print("zip() with callback")
+
+ # calculate 1/0
+ work = Work()
+ work.op = Operation.DIVIDE
+ work.num1 = 1
+ work.num2 = 0
+
+ try:
+ quotient = yield client.calculate(1, work)
+ print("Whoa? You know how to divide by zero ? -> {0}".format(quotient))
+ except InvalidOperation as io:
+ print("InvalidOperation: {0}".format(io))
+
+ # calculate 15-10
+ work.op = Operation.SUBTRACT
+ work.num1 = 15
+ work.num2 = 10
+
+ diff = yield client.calculate(1, work)
+ print("15 - 10 = {0}".format(diff))
+
+ # getStruct
+ log = yield client.getStruct(1)
+ print("Check log: {0}".format(log.value))
+
+ # close the transport
+ client._transport.close()
+ raise gen.Return()
+
+
+def main():
+ # create an ioloop, do the above, then stop
+ ioloop.IOLoop.current().run_sync(communicate)
+
+
+if __name__ == "__main__":
+ main()
diff --git a/src/jaegertracing/thrift/tutorial/py.tornado/PythonServer.py b/src/jaegertracing/thrift/tutorial/py.tornado/PythonServer.py
new file mode 100755
index 000000000..e0229a26e
--- /dev/null
+++ b/src/jaegertracing/thrift/tutorial/py.tornado/PythonServer.py
@@ -0,0 +1,100 @@
+#!/usr/bin/env python
+
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+import glob
+import sys
+
+sys.path.append('gen-py.tornado')
+sys.path.insert(0, glob.glob('../../lib/py/build/lib*')[0])
+
+from tutorial import Calculator
+from tutorial.ttypes import Operation, InvalidOperation
+
+from shared.ttypes import SharedStruct
+
+from thrift import TTornado
+from thrift.protocol import TBinaryProtocol
+
+from tornado import ioloop
+
+
+class CalculatorHandler(object):
+ def __init__(self):
+ self.log = {}
+
+ def ping(self):
+ print("ping()")
+
+ def add(self, n1, n2):
+ print("add({}, {})".format(n1, n2))
+ return n1 + n2
+
+ def calculate(self, logid, work):
+ print("calculate({}, {})".format(logid, work))
+
+ if work.op == Operation.ADD:
+ val = work.num1 + work.num2
+ elif work.op == Operation.SUBTRACT:
+ val = work.num1 - work.num2
+ elif work.op == Operation.MULTIPLY:
+ val = work.num1 * work.num2
+ elif work.op == Operation.DIVIDE:
+ if work.num2 == 0:
+ x = InvalidOperation()
+ x.whatOp = work.op
+ x.why = "Cannot divide by 0"
+ raise x
+ val = work.num1 / work.num2
+ else:
+ x = InvalidOperation()
+ x.whatOp = work.op
+ x.why = "Invalid operation"
+ raise x
+
+ log = SharedStruct()
+ log.key = logid
+ log.value = '%d' % (val)
+ self.log[logid] = log
+ return val
+
+ def getStruct(self, key):
+ print("getStruct({})".format(key))
+ return self.log[key]
+
+ def zip(self):
+ print("zip()")
+
+
+def main():
+ handler = CalculatorHandler()
+ processor = Calculator.Processor(handler)
+ pfactory = TBinaryProtocol.TBinaryProtocolFactory()
+ server = TTornado.TTornadoServer(processor, pfactory)
+
+ print("Starting the server...")
+ server.bind(9090)
+ server.start(1)
+ ioloop.IOLoop.instance().start()
+ print("done.")
+
+
+if __name__ == "__main__":
+ main()