summaryrefslogtreecommitdiffstats
path: root/src/mds/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/mds/CMakeLists.txt')
-rw-r--r--src/mds/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/src/mds/CMakeLists.txt b/src/mds/CMakeLists.txt
new file mode 100644
index 000000000..a12898f38
--- /dev/null
+++ b/src/mds/CMakeLists.txt
@@ -0,0 +1,53 @@
+set(mds_srcs
+ BatchOp.cc
+ Capability.cc
+ MDSDaemon.cc
+ MDSRank.cc
+ Beacon.cc
+ flock.cc
+ locks.c
+ journal.cc
+ Server.cc
+ Mutation.cc
+ MDCache.cc
+ RecoveryQueue.cc
+ StrayManager.cc
+ PurgeQueue.cc
+ Locker.cc
+ Migrator.cc
+ MDBalancer.cc
+ CDentry.cc
+ CDir.cc
+ CInode.cc
+ LogEvent.cc
+ MDSTable.cc
+ InoTable.cc
+ JournalPointer.cc
+ MDSTableClient.cc
+ MDSTableServer.cc
+ ScrubStack.cc
+ DamageTable.cc
+ SimpleLock.cc
+ SnapRealm.cc
+ SnapServer.cc
+ SnapClient.cc
+ snap.cc
+ SessionMap.cc
+ MDSContext.cc
+ MDSAuthCaps.cc
+ MDLog.cc
+ MDSCacheObject.cc
+ Mantle.cc
+ Anchor.cc
+ OpenFileTable.cc
+ MDSPinger.cc
+ MetricAggregator.cc
+ MetricsHandler.cc
+ ${CMAKE_SOURCE_DIR}/src/common/TrackedOp.cc
+ ${CMAKE_SOURCE_DIR}/src/common/MemoryModel.cc
+ ${CMAKE_SOURCE_DIR}/src/osdc/Journaler.cc
+ ${CMAKE_SOURCE_DIR}/src/mgr/MDSPerfMetricTypes.cc)
+add_library(mds STATIC ${mds_srcs})
+target_link_libraries(mds PRIVATE
+ heap_profiler cpu_profiler osdc ${LUA_LIBRARIES})
+target_include_directories(mds PRIVATE "${LUA_INCLUDE_DIR}")