summaryrefslogtreecommitdiffstats
path: root/src/mgr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/mgr/CMakeLists.txt')
-rw-r--r--src/mgr/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/mgr/CMakeLists.txt b/src/mgr/CMakeLists.txt
new file mode 100644
index 000000000..8e152e060
--- /dev/null
+++ b/src/mgr/CMakeLists.txt
@@ -0,0 +1,46 @@
+add_library(mgr_cap_obj OBJECT
+ MgrCap.cc)
+
+if(WITH_MGR)
+ set(mgr_srcs
+ ${CMAKE_SOURCE_DIR}/src/ceph_mgr.cc
+ ${CMAKE_SOURCE_DIR}/src/mon/PGMap.cc
+ ${CMAKE_SOURCE_DIR}/src/mon/ConfigMap.cc
+ ActivePyModule.cc
+ ActivePyModules.cc
+ BaseMgrModule.cc
+ BaseMgrStandbyModule.cc
+ ClusterState.cc
+ DaemonHealthMetricCollector.cc
+ DaemonKey.cc
+ DaemonServer.cc
+ DaemonState.cc
+ Gil.cc
+ Mgr.cc
+ mgr_perf_counters.cc
+ MgrStandby.cc
+ MetricCollector.cc
+ OSDPerfMetricTypes.cc
+ OSDPerfMetricCollector.cc
+ MDSPerfMetricTypes.cc
+ MDSPerfMetricCollector.cc
+ PyFormatter.cc
+ PyUtil.cc
+ PyModule.cc
+ PyModuleRegistry.cc
+ PyModuleRunner.cc
+ PyOSDMap.cc
+ StandbyPyModules.cc
+ mgr_commands.cc
+ $<TARGET_OBJECTS:mgr_cap_obj>)
+ add_executable(ceph-mgr ${mgr_srcs})
+ target_compile_definitions(ceph-mgr PRIVATE PY_SSIZE_T_CLEAN)
+ target_link_libraries(ceph-mgr
+ osdc client heap_profiler
+ global-static ceph-common
+ Boost::python${MGR_PYTHON_VERSION_MAJOR}${MGR_PYTHON_VERSION_MINOR}
+ Python3::Python ${CMAKE_DL_LIBS} ${GSSAPI_LIBRARIES})
+ set_target_properties(ceph-mgr PROPERTIES
+ POSITION_INDEPENDENT_CODE ${EXE_LINKER_USE_PIE})
+ install(TARGETS ceph-mgr DESTINATION bin)
+endif()