summaryrefslogtreecommitdiffstats
path: root/src/pybind/mgr/dashboard/frontend/tsconfig.spec.json
diff options
context:
space:
mode:
Diffstat (limited to 'src/pybind/mgr/dashboard/frontend/tsconfig.spec.json')
-rw-r--r--src/pybind/mgr/dashboard/frontend/tsconfig.spec.json21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/pybind/mgr/dashboard/frontend/tsconfig.spec.json b/src/pybind/mgr/dashboard/frontend/tsconfig.spec.json
new file mode 100644
index 000000000..e1889d6c6
--- /dev/null
+++ b/src/pybind/mgr/dashboard/frontend/tsconfig.spec.json
@@ -0,0 +1,21 @@
+{
+ "extends": "./tsconfig.json",
+ "compilerOptions": {
+ "outDir": "./out-tsc/spec",
+ "module": "commonjs",
+ "target": "es2015",
+ "types": [
+ "jest",
+ "node"
+ ],
+ "noEmit": true
+ },
+ "files": [
+ "src/polyfills.ts"
+ ],
+ "include": [
+ "src/**/*.spec.ts",
+ "src/**/*.d.ts",
+ "src/testing/*.ts"
+ ]
+}