summaryrefslogtreecommitdiffstats
path: root/src/spdk/app/iscsi_tgt
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/app/iscsi_tgt')
-rw-r--r--src/spdk/app/iscsi_tgt/.gitignore1
-rw-r--r--src/spdk/app/iscsi_tgt/Makefile59
-rw-r--r--src/spdk/app/iscsi_tgt/iscsi_tgt.c120
3 files changed, 180 insertions, 0 deletions
diff --git a/src/spdk/app/iscsi_tgt/.gitignore b/src/spdk/app/iscsi_tgt/.gitignore
new file mode 100644
index 000000000..14d948c59
--- /dev/null
+++ b/src/spdk/app/iscsi_tgt/.gitignore
@@ -0,0 +1 @@
+iscsi_tgt
diff --git a/src/spdk/app/iscsi_tgt/Makefile b/src/spdk/app/iscsi_tgt/Makefile
new file mode 100644
index 000000000..6b695d91a
--- /dev/null
+++ b/src/spdk/app/iscsi_tgt/Makefile
@@ -0,0 +1,59 @@
+#
+# BSD LICENSE
+#
+# Copyright (c) Intel Corporation.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Intel Corporation nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/../..)
+include $(SPDK_ROOT_DIR)/mk/spdk.common.mk
+include $(SPDK_ROOT_DIR)/mk/spdk.modules.mk
+
+APP = iscsi_tgt
+
+# Add iSCSI library directory to include path
+# TODO: remove this once iSCSI has a public API header
+CFLAGS += -I$(SPDK_ROOT_DIR)/lib
+
+C_SRCS := iscsi_tgt.c
+
+SPDK_LIB_LIST = $(ALL_MODULES_LIST)
+SPDK_LIB_LIST += $(EVENT_BDEV_SUBSYSTEM) event_iscsi event_net event_scsi event
+SPDK_LIB_LIST += jsonrpc json rpc bdev_rpc bdev iscsi scsi accel trace conf
+SPDK_LIB_LIST += thread util log log_rpc app_rpc net sock notify
+
+ifeq ($(SPDK_ROOT_DIR)/lib/env_dpdk,$(CONFIG_ENV))
+SPDK_LIB_LIST += env_dpdk_rpc
+endif
+
+ifeq ($(OS),Linux)
+SPDK_LIB_LIST += event_nbd nbd
+endif
+
+include $(SPDK_ROOT_DIR)/mk/spdk.app.mk
diff --git a/src/spdk/app/iscsi_tgt/iscsi_tgt.c b/src/spdk/app/iscsi_tgt/iscsi_tgt.c
new file mode 100644
index 000000000..b780a3771
--- /dev/null
+++ b/src/spdk/app/iscsi_tgt/iscsi_tgt.c
@@ -0,0 +1,120 @@
+/*-
+ * BSD LICENSE
+ *
+ * Copyright (c) Intel Corporation.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * * Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * * Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in
+ * the documentation and/or other materials provided with the
+ * distribution.
+ * * Neither the name of Intel Corporation nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#include "spdk/stdinc.h"
+
+#include "spdk/env.h"
+#include "spdk/event.h"
+#include "iscsi/iscsi.h"
+#include "spdk/log.h"
+#include "spdk/net.h"
+
+static int g_daemon_mode = 0;
+
+static void
+spdk_sigusr1(int signo __attribute__((__unused__)))
+{
+ char *config_str = NULL;
+ if (spdk_app_get_running_config(&config_str, "iscsi.conf") < 0) {
+ fprintf(stderr, "Error getting config\n");
+ } else {
+ fprintf(stdout, "============================\n");
+ fprintf(stdout, " iSCSI target running config\n");
+ fprintf(stdout, "=============================\n");
+ fprintf(stdout, "%s", config_str);
+ }
+ free(config_str);
+}
+
+static void
+iscsi_usage(void)
+{
+ printf(" -b run iscsi target background, the default is foreground\n");
+}
+
+static void
+spdk_startup(void *arg1)
+{
+ if (getenv("MEMZONE_DUMP") != NULL) {
+ spdk_memzone_dump(stdout);
+ fflush(stdout);
+ }
+}
+
+static int
+iscsi_parse_arg(int ch, char *arg)
+{
+ switch (ch) {
+ case 'b':
+ g_daemon_mode = 1;
+ break;
+ default:
+ return -EINVAL;
+ }
+ return 0;
+}
+
+int
+main(int argc, char **argv)
+{
+ int rc;
+ struct spdk_app_opts opts = {};
+
+ spdk_app_opts_init(&opts);
+ opts.name = "iscsi";
+ if ((rc = spdk_app_parse_args(argc, argv, &opts, "b", NULL,
+ iscsi_parse_arg, iscsi_usage)) !=
+ SPDK_APP_PARSE_ARGS_SUCCESS) {
+ exit(rc);
+ }
+
+ if (g_daemon_mode) {
+ if (daemon(1, 0) < 0) {
+ SPDK_ERRLOG("Start iscsi target daemon failed.\n");
+ exit(EXIT_FAILURE);
+ }
+ }
+
+ opts.shutdown_cb = NULL;
+ opts.usr1_handler = spdk_sigusr1;
+
+ /* Blocks until the application is exiting */
+ rc = spdk_app_start(&opts, spdk_startup, NULL);
+ if (rc) {
+ SPDK_ERRLOG("Start iscsi target daemon: spdk_app_start() retn non-zero\n");
+ }
+
+ spdk_app_fini();
+
+ return rc;
+}