summaryrefslogtreecommitdiffstats
path: root/src/spdk/lib/log
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/lib/log')
-rw-r--r--src/spdk/lib/log/Makefile46
-rw-r--r--src/spdk/lib/log/log.c203
-rw-r--r--src/spdk/lib/log/log_flags.c188
-rw-r--r--src/spdk/lib/log/spdk_log.map25
4 files changed, 462 insertions, 0 deletions
diff --git a/src/spdk/lib/log/Makefile b/src/spdk/lib/log/Makefile
new file mode 100644
index 000000000..4e7c25758
--- /dev/null
+++ b/src/spdk/lib/log/Makefile
@@ -0,0 +1,46 @@
+#
+# BSD LICENSE
+#
+# Copyright (c) Intel Corporation.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Intel Corporation nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/../..)
+include $(SPDK_ROOT_DIR)/mk/spdk.common.mk
+
+SO_VER := 3
+SO_MINOR := 0
+SO_SUFFIX := $(SO_VER).$(SO_MINOR)
+
+C_SRCS = log.c log_flags.c
+LIBNAME = log
+
+SPDK_MAP_FILE = $(abspath $(CURDIR)/spdk_log.map)
+
+include $(SPDK_ROOT_DIR)/mk/spdk.lib.mk
diff --git a/src/spdk/lib/log/log.c b/src/spdk/lib/log/log.c
new file mode 100644
index 000000000..0ab50d69c
--- /dev/null
+++ b/src/spdk/lib/log/log.c
@@ -0,0 +1,203 @@
+/*-
+ * BSD LICENSE
+ *
+ * Copyright (c) Intel Corporation.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * * Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * * Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in
+ * the documentation and/or other materials provided with the
+ * distribution.
+ * * Neither the name of Intel Corporation nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#include "spdk/stdinc.h"
+
+#include "spdk_internal/log.h"
+
+static const char *const spdk_level_names[] = {
+ [SPDK_LOG_ERROR] = "ERROR",
+ [SPDK_LOG_WARN] = "WARNING",
+ [SPDK_LOG_NOTICE] = "NOTICE",
+ [SPDK_LOG_INFO] = "INFO",
+ [SPDK_LOG_DEBUG] = "DEBUG",
+};
+
+#define MAX_TMPBUF 1024
+
+static logfunc *g_log = NULL;
+
+void
+spdk_log_open(logfunc *logf)
+{
+ if (logf) {
+ g_log = logf;
+ } else {
+ openlog("spdk", LOG_PID, LOG_LOCAL7);
+ }
+}
+
+void
+spdk_log_close(void)
+{
+ if (!g_log) {
+ closelog();
+ }
+}
+
+static void
+get_timestamp_prefix(char *buf, int buf_size)
+{
+ struct tm *info;
+ char date[24];
+ struct timespec ts;
+ long usec;
+
+ clock_gettime(CLOCK_REALTIME, &ts);
+ info = localtime(&ts.tv_sec);
+ usec = ts.tv_nsec / 1000;
+ if (info == NULL) {
+ snprintf(buf, buf_size, "[%s.%06ld] ", "unknown date", usec);
+ return;
+ }
+
+ strftime(date, sizeof(date), "%Y-%m-%d %H:%M:%S", info);
+ snprintf(buf, buf_size, "[%s.%06ld] ", date, usec);
+}
+
+void
+spdk_log(enum spdk_log_level level, const char *file, const int line, const char *func,
+ const char *format, ...)
+{
+ va_list ap;
+
+ va_start(ap, format);
+ spdk_vlog(level, file, line, func, format, ap);
+ va_end(ap);
+}
+
+void
+spdk_vlog(enum spdk_log_level level, const char *file, const int line, const char *func,
+ const char *format, va_list ap)
+{
+ int severity = LOG_INFO;
+ char buf[MAX_TMPBUF];
+ char timestamp[64];
+
+ if (g_log) {
+ g_log(level, file, line, func, format, ap);
+ return;
+ }
+
+ if (level > g_spdk_log_print_level && level > g_spdk_log_level) {
+ return;
+ }
+
+ switch (level) {
+ case SPDK_LOG_ERROR:
+ severity = LOG_ERR;
+ break;
+ case SPDK_LOG_WARN:
+ severity = LOG_WARNING;
+ break;
+ case SPDK_LOG_NOTICE:
+ severity = LOG_NOTICE;
+ break;
+ case SPDK_LOG_INFO:
+ case SPDK_LOG_DEBUG:
+ severity = LOG_INFO;
+ break;
+ case SPDK_LOG_DISABLED:
+ return;
+ }
+
+ vsnprintf(buf, sizeof(buf), format, ap);
+
+ if (level <= g_spdk_log_print_level) {
+ get_timestamp_prefix(timestamp, sizeof(timestamp));
+ if (file) {
+ fprintf(stderr, "%s%s:%4d:%s: *%s*: %s", timestamp, file, line, func, spdk_level_names[level], buf);
+ } else {
+ fprintf(stderr, "%s%s", timestamp, buf);
+ }
+ }
+
+ if (level <= g_spdk_log_level) {
+ if (file) {
+ syslog(severity, "%s:%4d:%s: *%s*: %s", file, line, func, spdk_level_names[level], buf);
+ } else {
+ syslog(severity, "%s", buf);
+ }
+ }
+}
+
+static void
+fdump(FILE *fp, const char *label, const uint8_t *buf, size_t len)
+{
+ char tmpbuf[MAX_TMPBUF];
+ char buf16[16 + 1];
+ size_t total;
+ unsigned int idx;
+
+ fprintf(fp, "%s\n", label);
+
+ memset(buf16, 0, sizeof buf16);
+ total = 0;
+ for (idx = 0; idx < len; idx++) {
+ if (idx != 0 && idx % 16 == 0) {
+ snprintf(tmpbuf + total, sizeof tmpbuf - total,
+ " %s", buf16);
+ memset(buf16, 0, sizeof buf16);
+ fprintf(fp, "%s\n", tmpbuf);
+ total = 0;
+ }
+ if (idx % 16 == 0) {
+ total += snprintf(tmpbuf + total, sizeof tmpbuf - total,
+ "%08x ", idx);
+ }
+ if (idx % 8 == 0) {
+ total += snprintf(tmpbuf + total, sizeof tmpbuf - total,
+ "%s", " ");
+ }
+ total += snprintf(tmpbuf + total, sizeof tmpbuf - total,
+ "%2.2x ", buf[idx] & 0xff);
+ buf16[idx % 16] = isprint(buf[idx]) ? buf[idx] : '.';
+ }
+ for (; idx % 16 != 0; idx++) {
+ if (idx == 8) {
+ total += snprintf(tmpbuf + total, sizeof tmpbuf - total,
+ " ");
+ }
+
+ total += snprintf(tmpbuf + total, sizeof tmpbuf - total, " ");
+ }
+ snprintf(tmpbuf + total, sizeof tmpbuf - total, " %s", buf16);
+ fprintf(fp, "%s\n", tmpbuf);
+ fflush(fp);
+}
+
+void
+spdk_log_dump(FILE *fp, const char *label, const void *buf, size_t len)
+{
+ fdump(fp, label, buf, len);
+}
diff --git a/src/spdk/lib/log/log_flags.c b/src/spdk/lib/log/log_flags.c
new file mode 100644
index 000000000..c767a3786
--- /dev/null
+++ b/src/spdk/lib/log/log_flags.c
@@ -0,0 +1,188 @@
+/*-
+ * BSD LICENSE
+ *
+ * Copyright (c) Intel Corporation.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * * Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * * Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in
+ * the documentation and/or other materials provided with the
+ * distribution.
+ * * Neither the name of Intel Corporation nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#include "spdk/stdinc.h"
+
+#include "spdk_internal/log.h"
+
+static TAILQ_HEAD(, spdk_log_flag) g_log_flags = TAILQ_HEAD_INITIALIZER(g_log_flags);
+
+enum spdk_log_level g_spdk_log_level = SPDK_LOG_NOTICE;
+enum spdk_log_level g_spdk_log_print_level = SPDK_LOG_NOTICE;
+
+SPDK_LOG_REGISTER_COMPONENT("log", SPDK_LOG_LOG)
+
+#define MAX_TMPBUF 1024
+
+void
+spdk_log_set_level(enum spdk_log_level level)
+{
+ assert(level >= SPDK_LOG_DISABLED);
+ assert(level <= SPDK_LOG_DEBUG);
+ g_spdk_log_level = level;
+}
+
+enum spdk_log_level
+spdk_log_get_level(void) {
+ return g_spdk_log_level;
+}
+
+void
+spdk_log_set_print_level(enum spdk_log_level level)
+{
+ assert(level >= SPDK_LOG_DISABLED);
+ assert(level <= SPDK_LOG_DEBUG);
+ g_spdk_log_print_level = level;
+}
+
+enum spdk_log_level
+spdk_log_get_print_level(void) {
+ return g_spdk_log_print_level;
+}
+
+static struct spdk_log_flag *
+get_log_flag(const char *name)
+{
+ struct spdk_log_flag *flag;
+
+ TAILQ_FOREACH(flag, &g_log_flags, tailq) {
+ if (strcasecmp(name, flag->name) == 0) {
+ return flag;
+ }
+ }
+
+ return NULL;
+}
+
+void
+spdk_log_register_flag(const char *name, struct spdk_log_flag *flag)
+{
+ struct spdk_log_flag *iter;
+
+ if (name == NULL || flag == NULL) {
+ SPDK_ERRLOG("missing spdk_log_flag parameters\n");
+ assert(false);
+ return;
+ }
+
+ if (get_log_flag(name)) {
+ SPDK_ERRLOG("duplicate spdk_log_flag '%s'\n", name);
+ assert(false);
+ return;
+ }
+
+ TAILQ_FOREACH(iter, &g_log_flags, tailq) {
+ if (strcasecmp(iter->name, flag->name) > 0) {
+ TAILQ_INSERT_BEFORE(iter, flag, tailq);
+ return;
+ }
+ }
+
+ TAILQ_INSERT_TAIL(&g_log_flags, flag, tailq);
+}
+
+bool
+spdk_log_get_flag(const char *name)
+{
+ struct spdk_log_flag *flag = get_log_flag(name);
+
+ if (flag && flag->enabled) {
+ return true;
+ }
+
+ return false;
+}
+
+static int
+log_set_flag(const char *name, bool value)
+{
+ struct spdk_log_flag *flag;
+
+ if (strcasecmp(name, "all") == 0) {
+ TAILQ_FOREACH(flag, &g_log_flags, tailq) {
+ flag->enabled = value;
+ }
+ return 0;
+ }
+
+ flag = get_log_flag(name);
+ if (flag == NULL) {
+ return -1;
+ }
+
+ flag->enabled = value;
+
+ return 0;
+}
+
+int
+spdk_log_set_flag(const char *name)
+{
+ return log_set_flag(name, true);
+}
+
+int
+spdk_log_clear_flag(const char *name)
+{
+ return log_set_flag(name, false);
+}
+
+struct spdk_log_flag *
+spdk_log_get_first_flag(void)
+{
+ return TAILQ_FIRST(&g_log_flags);
+}
+
+struct spdk_log_flag *
+spdk_log_get_next_flag(struct spdk_log_flag *flag)
+{
+ return TAILQ_NEXT(flag, tailq);
+}
+
+void
+spdk_log_usage(FILE *f, const char *log_arg)
+{
+#ifdef DEBUG
+ struct spdk_log_flag *flag;
+ fprintf(f, " %s, --logflag <flag> enable debug log flag (all", log_arg);
+
+ TAILQ_FOREACH(flag, &g_log_flags, tailq) {
+ fprintf(f, ", %s", flag->name);
+ }
+
+ fprintf(f, ")\n");
+#else
+ fprintf(f, " %s, --logflag <flag> enable debug log flag (not supported"
+ " - must reconfigure with --enable-debug)\n", log_arg);
+#endif
+}
diff --git a/src/spdk/lib/log/spdk_log.map b/src/spdk/lib/log/spdk_log.map
new file mode 100644
index 000000000..84629d555
--- /dev/null
+++ b/src/spdk/lib/log/spdk_log.map
@@ -0,0 +1,25 @@
+{
+ global:
+
+ # public functions
+ spdk_log_open;
+ spdk_log_close;
+ spdk_log_set_level;
+ spdk_log_get_level;
+ spdk_log_set_print_level;
+ spdk_log_get_print_level;
+ spdk_log;
+ spdk_vlog;
+ spdk_log_dump;
+ spdk_log_get_flag;
+ spdk_log_set_flag;
+ spdk_log_clear_flag;
+ spdk_log_usage;
+
+ # functions used by other SPDK libraries
+ spdk_log_register_flag;
+ spdk_log_get_first_flag;
+ spdk_log_get_next_flag;
+
+ local: *;
+};