summaryrefslogtreecommitdiffstats
path: root/src/spdk/lib/notify
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/lib/notify')
-rw-r--r--src/spdk/lib/notify/Makefile45
-rw-r--r--src/spdk/lib/notify/notify.c150
-rw-r--r--src/spdk/lib/notify/notify_rpc.c126
-rw-r--r--src/spdk/lib/notify/spdk_notify.map10
4 files changed, 331 insertions, 0 deletions
diff --git a/src/spdk/lib/notify/Makefile b/src/spdk/lib/notify/Makefile
new file mode 100644
index 000000000..82249a5b2
--- /dev/null
+++ b/src/spdk/lib/notify/Makefile
@@ -0,0 +1,45 @@
+#
+# BSD LICENSE
+#
+# Copyright (c) Intel Corporation.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Intel Corporation nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/../..)
+include $(SPDK_ROOT_DIR)/mk/spdk.common.mk
+
+SO_VER := 2
+SO_MINOR := 0
+
+C_SRCS = notify.c notify_rpc.c
+LIBNAME = notify
+
+SPDK_MAP_FILE = $(abspath $(CURDIR)/spdk_notify.map)
+
+include $(SPDK_ROOT_DIR)/mk/spdk.lib.mk
diff --git a/src/spdk/lib/notify/notify.c b/src/spdk/lib/notify/notify.c
new file mode 100644
index 000000000..88c5d633b
--- /dev/null
+++ b/src/spdk/lib/notify/notify.c
@@ -0,0 +1,150 @@
+/*-
+ * BSD LICENSE
+ *
+ * Copyright (c) Intel Corporation.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * * Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * * Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in
+ * the documentation and/or other materials provided with the
+ * distribution.
+ * * Neither the name of Intel Corporation nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#include <sys/queue.h>
+
+#include "spdk/stdinc.h"
+#include "spdk/util.h"
+#include "spdk/queue.h"
+#include "spdk/string.h"
+#include "spdk/log.h"
+
+#include "spdk/notify.h"
+
+#define SPDK_NOTIFY_MAX_EVENTS 1024
+
+struct spdk_notify_type {
+ char name[SPDK_NOTIFY_MAX_NAME_SIZE];
+ TAILQ_ENTRY(spdk_notify_type) tailq;
+};
+
+pthread_mutex_t g_events_lock = PTHREAD_MUTEX_INITIALIZER;
+static struct spdk_notify_event g_events[SPDK_NOTIFY_MAX_EVENTS];
+static uint64_t g_events_head;
+
+static TAILQ_HEAD(, spdk_notify_type) g_notify_types = TAILQ_HEAD_INITIALIZER(g_notify_types);
+
+struct spdk_notify_type *
+spdk_notify_type_register(const char *type)
+{
+ struct spdk_notify_type *it = NULL;
+
+ if (!type) {
+ SPDK_ERRLOG("Invalid notification type %p\n", type);
+ return NULL;
+ } else if (!type[0] || strlen(type) >= SPDK_NOTIFY_MAX_NAME_SIZE) {
+ SPDK_ERRLOG("Notification type '%s' too short or too long\n", type);
+ return NULL;
+ }
+
+ pthread_mutex_lock(&g_events_lock);
+ TAILQ_FOREACH(it, &g_notify_types, tailq) {
+ if (strcmp(type, it->name) == 0) {
+ SPDK_NOTICELOG("Notification type '%s' already registered.\n", type);
+ goto out;
+ }
+ }
+
+ it = calloc(1, sizeof(*it));
+ if (it == NULL) {
+ goto out;
+ }
+
+ snprintf(it->name, sizeof(it->name), "%s", type);
+ TAILQ_INSERT_TAIL(&g_notify_types, it, tailq);
+
+out:
+ pthread_mutex_unlock(&g_events_lock);
+ return it;
+}
+
+const char *
+spdk_notify_type_get_name(const struct spdk_notify_type *type)
+{
+ return type->name;
+}
+
+
+void
+spdk_notify_foreach_type(spdk_notify_foreach_type_cb cb, void *ctx)
+{
+ struct spdk_notify_type *it;
+
+ pthread_mutex_lock(&g_events_lock);
+ TAILQ_FOREACH(it, &g_notify_types, tailq) {
+ if (cb(it, ctx)) {
+ break;
+ }
+ }
+ pthread_mutex_unlock(&g_events_lock);
+}
+
+uint64_t
+spdk_notify_send(const char *type, const char *ctx)
+{
+ uint64_t head;
+ struct spdk_notify_event *ev;
+
+ pthread_mutex_lock(&g_events_lock);
+ head = g_events_head;
+ g_events_head++;
+
+ ev = &g_events[head % SPDK_NOTIFY_MAX_EVENTS];
+ spdk_strcpy_pad(ev->type, type, sizeof(ev->type), '\0');
+ spdk_strcpy_pad(ev->ctx, ctx, sizeof(ev->ctx), '\0');
+ pthread_mutex_unlock(&g_events_lock);
+
+ return head;
+}
+
+uint64_t
+spdk_notify_foreach_event(uint64_t start_idx, uint64_t max,
+ spdk_notify_foreach_event_cb cb_fn, void *ctx)
+{
+ uint64_t i;
+
+ pthread_mutex_lock(&g_events_lock);
+
+ if (g_events_head > SPDK_NOTIFY_MAX_EVENTS && start_idx < g_events_head - SPDK_NOTIFY_MAX_EVENTS) {
+ start_idx = g_events_head - SPDK_NOTIFY_MAX_EVENTS;
+ }
+
+ for (i = 0; start_idx < g_events_head && i < max; start_idx++, i++) {
+ if (cb_fn(start_idx, &g_events[start_idx % SPDK_NOTIFY_MAX_EVENTS], ctx)) {
+ break;
+ }
+ }
+ pthread_mutex_unlock(&g_events_lock);
+
+ return i;
+}
diff --git a/src/spdk/lib/notify/notify_rpc.c b/src/spdk/lib/notify/notify_rpc.c
new file mode 100644
index 000000000..fc40502c2
--- /dev/null
+++ b/src/spdk/lib/notify/notify_rpc.c
@@ -0,0 +1,126 @@
+/*-
+ * BSD LICENSE
+ *
+ * Copyright (c) Intel Corporation.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * * Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * * Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in
+ * the documentation and/or other materials provided with the
+ * distribution.
+ * * Neither the name of Intel Corporation nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+
+#include "spdk/rpc.h"
+#include "spdk/string.h"
+#include "spdk/notify.h"
+#include "spdk/env.h"
+#include "spdk/util.h"
+
+#include "spdk_internal/log.h"
+
+static int
+notify_get_types_cb(const struct spdk_notify_type *type, void *ctx)
+{
+ spdk_json_write_string((struct spdk_json_write_ctx *)ctx, spdk_notify_type_get_name(type));
+ return 0;
+}
+
+static void
+rpc_notify_get_types(struct spdk_jsonrpc_request *request,
+ const struct spdk_json_val *params)
+{
+ struct spdk_json_write_ctx *w;
+
+ if (params != NULL) {
+ spdk_jsonrpc_send_error_response(request, SPDK_JSONRPC_ERROR_INVALID_PARAMS,
+ "No parameters required");
+ return;
+ }
+
+ w = spdk_jsonrpc_begin_result(request);
+ spdk_json_write_array_begin(w);
+ spdk_notify_foreach_type(notify_get_types_cb, w);
+ spdk_json_write_array_end(w);
+
+ spdk_jsonrpc_end_result(request, w);
+}
+SPDK_RPC_REGISTER("notify_get_types", rpc_notify_get_types, SPDK_RPC_RUNTIME)
+SPDK_RPC_REGISTER_ALIAS_DEPRECATED(notify_get_types, get_notification_types)
+
+struct rpc_notify_get_notifications {
+ uint64_t id;
+ uint64_t max;
+
+ struct spdk_json_write_ctx *w;
+};
+
+static const struct spdk_json_object_decoder rpc_notify_get_notifications_decoders[] = {
+ {"id", offsetof(struct rpc_notify_get_notifications, id), spdk_json_decode_uint64, true},
+ {"max", offsetof(struct rpc_notify_get_notifications, max), spdk_json_decode_uint64, true},
+};
+
+
+static int
+notify_get_notifications_cb(uint64_t id, const struct spdk_notify_event *ev, void *ctx)
+{
+ struct rpc_notify_get_notifications *req = ctx;
+
+ spdk_json_write_object_begin(req->w);
+ spdk_json_write_named_string(req->w, "type", ev->type);
+ spdk_json_write_named_string(req->w, "ctx", ev->ctx);
+ spdk_json_write_named_uint64(req->w, "id", id);
+ spdk_json_write_object_end(req->w);
+ return 0;
+}
+
+static void
+rpc_notify_get_notifications(struct spdk_jsonrpc_request *request,
+ const struct spdk_json_val *params)
+{
+ struct rpc_notify_get_notifications req = {0, UINT64_MAX};
+
+ if (params &&
+ spdk_json_decode_object(params, rpc_notify_get_notifications_decoders,
+ SPDK_COUNTOF(rpc_notify_get_notifications_decoders), &req)) {
+ SPDK_DEBUGLOG(SPDK_NOTIFY_RPC, "spdk_json_decode_object failed\n");
+
+ spdk_jsonrpc_send_error_response(request, SPDK_JSONRPC_ERROR_INVALID_PARAMS,
+ spdk_strerror(EINVAL));
+ return;
+ }
+
+
+ req.w = spdk_jsonrpc_begin_result(request);
+
+ spdk_json_write_array_begin(req.w);
+ spdk_notify_foreach_event(req.id, req.max, notify_get_notifications_cb, &req);
+ spdk_json_write_array_end(req.w);
+
+ spdk_jsonrpc_end_result(request, req.w);
+}
+SPDK_RPC_REGISTER("notify_get_notifications", rpc_notify_get_notifications, SPDK_RPC_RUNTIME)
+SPDK_RPC_REGISTER_ALIAS_DEPRECATED(notify_get_notifications, get_notifications)
+
+SPDK_LOG_REGISTER_COMPONENT("notify_rpc", SPDK_NOTIFY_RPC)
diff --git a/src/spdk/lib/notify/spdk_notify.map b/src/spdk/lib/notify/spdk_notify.map
new file mode 100644
index 000000000..4023a8e66
--- /dev/null
+++ b/src/spdk/lib/notify/spdk_notify.map
@@ -0,0 +1,10 @@
+{
+ global:
+ spdk_notify_type_register;
+ spdk_notify_type_get_name;
+ spdk_notify_foreach_type;
+ spdk_notify_send;
+ spdk_notify_foreach_event;
+
+ local: *;
+};