summaryrefslogtreecommitdiffstats
path: root/src/spdk/test/env/env_dpdk_post_init
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/test/env/env_dpdk_post_init')
-rw-r--r--src/spdk/test/env/env_dpdk_post_init/.gitignore1
-rw-r--r--src/spdk/test/env/env_dpdk_post_init/Makefile39
-rw-r--r--src/spdk/test/env/env_dpdk_post_init/env_dpdk_post_init.c126
3 files changed, 166 insertions, 0 deletions
diff --git a/src/spdk/test/env/env_dpdk_post_init/.gitignore b/src/spdk/test/env/env_dpdk_post_init/.gitignore
new file mode 100644
index 000000000..39bd89884
--- /dev/null
+++ b/src/spdk/test/env/env_dpdk_post_init/.gitignore
@@ -0,0 +1 @@
+env_dpdk_post_init
diff --git a/src/spdk/test/env/env_dpdk_post_init/Makefile b/src/spdk/test/env/env_dpdk_post_init/Makefile
new file mode 100644
index 000000000..ea0ff7bb7
--- /dev/null
+++ b/src/spdk/test/env/env_dpdk_post_init/Makefile
@@ -0,0 +1,39 @@
+#
+# BSD LICENSE
+#
+# Copyright (c) Intel Corporation.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Intel Corporation nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/../../..)
+
+CFLAGS += $(ENV_CFLAGS)
+APP = env_dpdk_post_init
+
+include $(SPDK_ROOT_DIR)/mk/nvme.libtest.mk
diff --git a/src/spdk/test/env/env_dpdk_post_init/env_dpdk_post_init.c b/src/spdk/test/env/env_dpdk_post_init/env_dpdk_post_init.c
new file mode 100644
index 000000000..1b3897ea8
--- /dev/null
+++ b/src/spdk/test/env/env_dpdk_post_init/env_dpdk_post_init.c
@@ -0,0 +1,126 @@
+/*-
+ * BSD LICENSE
+ *
+ * Copyright (c) Intel Corporation.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * * Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * * Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in
+ * the documentation and/or other materials provided with the
+ * distribution.
+ * * Neither the name of Intel Corporation nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#include "spdk/stdinc.h"
+
+#include "spdk/nvme.h"
+#include "spdk/env.h"
+#include "spdk/env_dpdk.h"
+#include <rte_config.h>
+#include <rte_eal.h>
+
+#define MAX_DEVS 64
+
+struct dev {
+ struct spdk_nvme_ctrlr *ctrlr;
+ struct spdk_nvme_ns *ns;
+ struct spdk_nvme_qpair *qpair;
+ char name[SPDK_NVMF_TRADDR_MAX_LEN + 1];
+};
+
+static struct dev g_nvme_devs[MAX_DEVS];
+static int g_num_devs = 0;
+static int g_failed = 0;
+
+static bool
+probe_cb(void *cb_ctx, const struct spdk_nvme_transport_id *trid,
+ struct spdk_nvme_ctrlr_opts *opts)
+{
+ printf("Attaching to %s\n", trid->traddr);
+
+ return true;
+}
+
+static void
+attach_cb(void *cb_ctx, const struct spdk_nvme_transport_id *trid,
+ struct spdk_nvme_ctrlr *ctrlr, const struct spdk_nvme_ctrlr_opts *opts)
+{
+ struct dev *dev;
+ uint32_t nsid;
+
+ /* add to dev list */
+ dev = &g_nvme_devs[g_num_devs++];
+ if (g_num_devs >= MAX_DEVS) {
+ return;
+ }
+
+ dev->ctrlr = ctrlr;
+ nsid = spdk_nvme_ctrlr_get_first_active_ns(ctrlr);
+ dev->ns = spdk_nvme_ctrlr_get_ns(ctrlr, nsid);
+
+ dev->qpair = spdk_nvme_ctrlr_alloc_io_qpair(ctrlr, NULL, 0);
+ if (dev->qpair == NULL) {
+ g_failed = 1;
+ return;
+ }
+
+ snprintf(dev->name, sizeof(dev->name), "%s",
+ trid->traddr);
+
+ printf("Attached to %s\n", dev->name);
+}
+
+int
+main(int argc, char **argv)
+{
+ int ret;
+ int i;
+
+ printf("Starting DPDK initialization...\n");
+ ret = rte_eal_init(argc, argv);
+ if (ret < 0) {
+ fprintf(stderr, "Failed to initialize DPDK\n");
+ return -1;
+ }
+
+ printf("Starting SPDK post initialization...\n");
+ ret = spdk_env_dpdk_post_init(false);
+ if (ret < 0) {
+ fprintf(stderr, "Failed to initialize SPDK\n");
+ return -1;
+ }
+
+ printf("SPDK NVMe probe\n");
+ if (spdk_nvme_probe(NULL, NULL, probe_cb, attach_cb, NULL) != 0) {
+ fprintf(stderr, "spdk_nvme_probe() failed\n");
+ return 1;
+ }
+
+ printf("Cleaning up...\n");
+ for (i = 0; i < g_num_devs; i++) {
+ struct dev *dev = &g_nvme_devs[i];
+ spdk_nvme_detach(dev->ctrlr);
+ }
+
+ return g_failed;
+}