summaryrefslogtreecommitdiffstats
path: root/src/tools/erasure-code/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/erasure-code/CMakeLists.txt')
-rw-r--r--src/tools/erasure-code/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/tools/erasure-code/CMakeLists.txt b/src/tools/erasure-code/CMakeLists.txt
new file mode 100644
index 000000000..3583733f5
--- /dev/null
+++ b/src/tools/erasure-code/CMakeLists.txt
@@ -0,0 +1,5 @@
+add_executable(ceph-erasure-code-tool
+ ${PROJECT_SOURCE_DIR}/src/osd/ECUtil.cc
+ ceph-erasure-code-tool.cc)
+target_link_libraries(ceph-erasure-code-tool global ceph-common)
+install(TARGETS ceph-erasure-code-tool DESTINATION bin)