summaryrefslogtreecommitdiffstats
path: root/src/tools/rbd_wnbd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/tools/rbd_wnbd/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/tools/rbd_wnbd/CMakeLists.txt b/src/tools/rbd_wnbd/CMakeLists.txt
new file mode 100644
index 000000000..38f463961
--- /dev/null
+++ b/src/tools/rbd_wnbd/CMakeLists.txt
@@ -0,0 +1,10 @@
+add_executable(rbd-wnbd wnbd_handler.cc rbd_wnbd.cc)
+set_target_properties(
+ rbd-wnbd PROPERTIES COMPILE_FLAGS
+ "-fpermissive -I${WNBD_INCLUDE_DIRS}")
+target_link_libraries(
+ rbd-wnbd setupapi rpcrt4
+ ${WNBD_LIBRARIES}
+ ${Boost_FILESYSTEM_LIBRARY}
+ librbd librados global)
+install(TARGETS rbd-wnbd DESTINATION bin)