summaryrefslogtreecommitdiffstats
path: root/src/zstd/build/meson/contrib
diff options
context:
space:
mode:
Diffstat (limited to 'src/zstd/build/meson/contrib')
-rw-r--r--src/zstd/build/meson/contrib/gen_html/meson.build30
-rw-r--r--src/zstd/build/meson/contrib/meson.build12
-rw-r--r--src/zstd/build/meson/contrib/pzstd/meson.build24
3 files changed, 66 insertions, 0 deletions
diff --git a/src/zstd/build/meson/contrib/gen_html/meson.build b/src/zstd/build/meson/contrib/gen_html/meson.build
new file mode 100644
index 000000000..3f302538d
--- /dev/null
+++ b/src/zstd/build/meson/contrib/gen_html/meson.build
@@ -0,0 +1,30 @@
+# #############################################################################
+# Copyright (c) 2018-present lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+zstd_rootdir = '../../../..'
+
+gen_html_includes = include_directories(join_paths(zstd_rootdir, 'programs'),
+ join_paths(zstd_rootdir, 'lib'),
+ join_paths(zstd_rootdir, 'lib/common'),
+ join_paths(zstd_rootdir, 'contrib/gen_html'))
+
+gen_html = executable('gen_html',
+ join_paths(zstd_rootdir, 'contrib/gen_html/gen_html.cpp'),
+ include_directories: gen_html_includes,
+ native: true,
+ install: false)
+
+# Update zstd manual
+zstd_manual_html = custom_target('zstd_manual.html',
+ output : 'zstd_manual.html',
+ command : [gen_html,
+ zstd_version,
+ join_paths(meson.current_source_dir(), zstd_rootdir, 'lib/zstd.h'),
+ '@OUTPUT@'],
+ install : false)
diff --git a/src/zstd/build/meson/contrib/meson.build b/src/zstd/build/meson/contrib/meson.build
new file mode 100644
index 000000000..7f6d03a4c
--- /dev/null
+++ b/src/zstd/build/meson/contrib/meson.build
@@ -0,0 +1,12 @@
+# #############################################################################
+# Copyright (c) 2018-present Dima Krasner <dima@dimakrasner.com>
+# lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+subdir('pzstd')
+subdir('gen_html')
diff --git a/src/zstd/build/meson/contrib/pzstd/meson.build b/src/zstd/build/meson/contrib/pzstd/meson.build
new file mode 100644
index 000000000..8f3822fd7
--- /dev/null
+++ b/src/zstd/build/meson/contrib/pzstd/meson.build
@@ -0,0 +1,24 @@
+# #############################################################################
+# Copyright (c) 2018-present lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+zstd_rootdir = '../../../..'
+
+pzstd_includes = include_directories(join_paths(zstd_rootdir, 'programs'),
+ join_paths(zstd_rootdir, 'contrib/pzstd'))
+pzstd_sources = [join_paths(zstd_rootdir, 'programs/util.c'),
+ join_paths(zstd_rootdir, 'contrib/pzstd/main.cpp'),
+ join_paths(zstd_rootdir, 'contrib/pzstd/Options.cpp'),
+ join_paths(zstd_rootdir, 'contrib/pzstd/Pzstd.cpp'),
+ join_paths(zstd_rootdir, 'contrib/pzstd/SkippableFrame.cpp')]
+pzstd = executable('pzstd',
+ pzstd_sources,
+ cpp_args: [ '-DNDEBUG', '-Wno-shadow', '-pedantic' ],
+ include_directories: pzstd_includes,
+ dependencies: [ libzstd_dep, thread_dep ],
+ install: true)