summaryrefslogtreecommitdiffstats
path: root/src/zstd/build/meson
diff options
context:
space:
mode:
Diffstat (limited to 'src/zstd/build/meson')
-rw-r--r--src/zstd/build/meson/GetZstdLibraryVersion.py39
-rw-r--r--src/zstd/build/meson/InstallSymlink.py55
-rw-r--r--src/zstd/build/meson/README.md38
-rw-r--r--src/zstd/build/meson/contrib/gen_html/meson.build30
-rw-r--r--src/zstd/build/meson/contrib/meson.build12
-rw-r--r--src/zstd/build/meson/contrib/pzstd/meson.build24
-rw-r--r--src/zstd/build/meson/lib/meson.build132
-rw-r--r--src/zstd/build/meson/meson.build147
-rw-r--r--src/zstd/build/meson/meson_options.txt36
-rw-r--r--src/zstd/build/meson/programs/meson.build104
-rw-r--r--src/zstd/build/meson/tests/meson.build206
-rw-r--r--src/zstd/build/meson/tests/valgrindTest.py90
12 files changed, 913 insertions, 0 deletions
diff --git a/src/zstd/build/meson/GetZstdLibraryVersion.py b/src/zstd/build/meson/GetZstdLibraryVersion.py
new file mode 100644
index 000000000..461af5f9c
--- /dev/null
+++ b/src/zstd/build/meson/GetZstdLibraryVersion.py
@@ -0,0 +1,39 @@
+#!/usr/bin/env python3
+# #############################################################################
+# Copyright (c) 2018-present lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+import re
+
+
+def find_version_tuple(filepath):
+ version_file_data = None
+ with open(filepath) as fd:
+ version_file_data = fd.read()
+
+ patterns = r"""#\s*define\s+ZSTD_VERSION_MAJOR\s+([0-9]+)
+#\s*define\s+ZSTD_VERSION_MINOR\s+([0-9]+)
+#\s*define\s+ZSTD_VERSION_RELEASE\s+([0-9]+)
+"""
+ regex = re.compile(patterns, re.MULTILINE)
+ version_match = regex.search(version_file_data)
+ if version_match:
+ return version_match.groups()
+ raise Exception("Unable to find version string")
+
+
+def main():
+ import argparse
+ parser = argparse.ArgumentParser(description='Print zstd version from lib/zstd.h')
+ parser.add_argument('file', help='path to lib/zstd.h')
+ args = parser.parse_args()
+ version_tuple = find_version_tuple(args.file)
+ print('.'.join(version_tuple))
+
+
+if __name__ == '__main__':
+ main()
diff --git a/src/zstd/build/meson/InstallSymlink.py b/src/zstd/build/meson/InstallSymlink.py
new file mode 100644
index 000000000..3f2998c64
--- /dev/null
+++ b/src/zstd/build/meson/InstallSymlink.py
@@ -0,0 +1,55 @@
+#!/usr/bin/env python3
+# #############################################################################
+# Copyright (c) 2018-present lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+# This file should be synced with https://github.com/lzutao/meson-symlink
+
+import os
+import pathlib # since Python 3.4
+
+
+def install_symlink(src, dst, install_dir, dst_is_dir=False, dir_mode=0o777):
+ if not install_dir.exists():
+ install_dir.mkdir(mode=dir_mode, parents=True, exist_ok=True)
+ if not install_dir.is_dir():
+ raise NotADirectoryError(install_dir)
+
+ new_dst = install_dir.joinpath(dst)
+ if new_dst.is_symlink() and os.readlink(new_dst) == src:
+ print('File exists: {!r} -> {!r}'.format(new_dst, src))
+ return
+ print('Installing symlink {!r} -> {!r}'.format(new_dst, src))
+ new_dst.symlink_to(src, target_is_directory=dst_is_dir)
+
+
+def main():
+ import argparse
+ parser = argparse.ArgumentParser(description='Install a symlink',
+ usage='{0} [-h] [-d] [-m MODE] source dest install_dir\n\n'
+ 'example:\n'
+ ' {0} dash sh /bin'.format(pathlib.Path(__file__).name))
+ parser.add_argument('source', help='target to link')
+ parser.add_argument('dest', help='link name')
+ parser.add_argument('install_dir', help='installation directory')
+ parser.add_argument('-d', '--isdir',
+ action='store_true',
+ help='dest is a directory')
+ parser.add_argument('-m', '--mode',
+ help='directory mode on creating if not exist',
+ default='0o755')
+ args = parser.parse_args()
+
+ dir_mode = int(args.mode, 8)
+
+ meson_destdir = os.environ.get('MESON_INSTALL_DESTDIR_PREFIX', default='')
+ install_dir = pathlib.Path(meson_destdir, args.install_dir)
+ install_symlink(args.source, args.dest, install_dir, args.isdir, dir_mode)
+
+
+if __name__ == '__main__':
+ main()
diff --git a/src/zstd/build/meson/README.md b/src/zstd/build/meson/README.md
new file mode 100644
index 000000000..d393a063f
--- /dev/null
+++ b/src/zstd/build/meson/README.md
@@ -0,0 +1,38 @@
+Meson build system for zstandard
+================================
+
+Meson is a build system designed to optimize programmer productivity.
+It aims to do this by providing simple, out-of-the-box support for
+modern software development tools and practices, such as unit tests,
+coverage reports, Valgrind, CCache and the like.
+
+This Meson build system is provided with no guarantee and maintained
+by Dima Krasner \<dima@dimakrasner.com\>.
+
+It outputs one `libzstd`, either shared or static, depending on
+`default_library` option.
+
+## How to build
+
+`cd` to this meson directory (`build/meson`)
+
+```sh
+meson setup -Dbin_programs=true -Dbin_contrib=true builddir
+cd builddir
+ninja # to build
+ninja install # to install
+```
+
+You might want to install it in staging directory:
+
+```sh
+DESTDIR=./staging ninja install
+```
+
+To configure build options, use:
+
+```sh
+meson configure
+```
+
+See [man meson(1)](https://manpages.debian.org/testing/meson/meson.1.en.html).
diff --git a/src/zstd/build/meson/contrib/gen_html/meson.build b/src/zstd/build/meson/contrib/gen_html/meson.build
new file mode 100644
index 000000000..3f302538d
--- /dev/null
+++ b/src/zstd/build/meson/contrib/gen_html/meson.build
@@ -0,0 +1,30 @@
+# #############################################################################
+# Copyright (c) 2018-present lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+zstd_rootdir = '../../../..'
+
+gen_html_includes = include_directories(join_paths(zstd_rootdir, 'programs'),
+ join_paths(zstd_rootdir, 'lib'),
+ join_paths(zstd_rootdir, 'lib/common'),
+ join_paths(zstd_rootdir, 'contrib/gen_html'))
+
+gen_html = executable('gen_html',
+ join_paths(zstd_rootdir, 'contrib/gen_html/gen_html.cpp'),
+ include_directories: gen_html_includes,
+ native: true,
+ install: false)
+
+# Update zstd manual
+zstd_manual_html = custom_target('zstd_manual.html',
+ output : 'zstd_manual.html',
+ command : [gen_html,
+ zstd_version,
+ join_paths(meson.current_source_dir(), zstd_rootdir, 'lib/zstd.h'),
+ '@OUTPUT@'],
+ install : false)
diff --git a/src/zstd/build/meson/contrib/meson.build b/src/zstd/build/meson/contrib/meson.build
new file mode 100644
index 000000000..7f6d03a4c
--- /dev/null
+++ b/src/zstd/build/meson/contrib/meson.build
@@ -0,0 +1,12 @@
+# #############################################################################
+# Copyright (c) 2018-present Dima Krasner <dima@dimakrasner.com>
+# lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+subdir('pzstd')
+subdir('gen_html')
diff --git a/src/zstd/build/meson/contrib/pzstd/meson.build b/src/zstd/build/meson/contrib/pzstd/meson.build
new file mode 100644
index 000000000..8f3822fd7
--- /dev/null
+++ b/src/zstd/build/meson/contrib/pzstd/meson.build
@@ -0,0 +1,24 @@
+# #############################################################################
+# Copyright (c) 2018-present lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+zstd_rootdir = '../../../..'
+
+pzstd_includes = include_directories(join_paths(zstd_rootdir, 'programs'),
+ join_paths(zstd_rootdir, 'contrib/pzstd'))
+pzstd_sources = [join_paths(zstd_rootdir, 'programs/util.c'),
+ join_paths(zstd_rootdir, 'contrib/pzstd/main.cpp'),
+ join_paths(zstd_rootdir, 'contrib/pzstd/Options.cpp'),
+ join_paths(zstd_rootdir, 'contrib/pzstd/Pzstd.cpp'),
+ join_paths(zstd_rootdir, 'contrib/pzstd/SkippableFrame.cpp')]
+pzstd = executable('pzstd',
+ pzstd_sources,
+ cpp_args: [ '-DNDEBUG', '-Wno-shadow', '-pedantic' ],
+ include_directories: pzstd_includes,
+ dependencies: [ libzstd_dep, thread_dep ],
+ install: true)
diff --git a/src/zstd/build/meson/lib/meson.build b/src/zstd/build/meson/lib/meson.build
new file mode 100644
index 000000000..6fb3df8e9
--- /dev/null
+++ b/src/zstd/build/meson/lib/meson.build
@@ -0,0 +1,132 @@
+# #############################################################################
+# Copyright (c) 2018-present Dima Krasner <dima@dimakrasner.com>
+# lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+zstd_rootdir = '../../..'
+
+libzstd_includes = [include_directories(join_paths(zstd_rootdir,'lib'),
+ join_paths(zstd_rootdir, 'lib/common'),
+ join_paths(zstd_rootdir, 'lib/compress'),
+ join_paths(zstd_rootdir, 'lib/decompress'),
+ join_paths(zstd_rootdir, 'lib/dictBuilder'),
+ join_paths(zstd_rootdir, 'lib/deprecated'))]
+
+libzstd_sources = [join_paths(zstd_rootdir, 'lib/common/entropy_common.c'),
+ join_paths(zstd_rootdir, 'lib/common/fse_decompress.c'),
+ join_paths(zstd_rootdir, 'lib/common/threading.c'),
+ join_paths(zstd_rootdir, 'lib/common/pool.c'),
+ join_paths(zstd_rootdir, 'lib/common/zstd_common.c'),
+ join_paths(zstd_rootdir, 'lib/common/error_private.c'),
+ join_paths(zstd_rootdir, 'lib/common/xxhash.c'),
+ join_paths(zstd_rootdir, 'lib/compress/hist.c'),
+ join_paths(zstd_rootdir, 'lib/compress/fse_compress.c'),
+ join_paths(zstd_rootdir, 'lib/compress/huf_compress.c'),
+ join_paths(zstd_rootdir, 'lib/compress/zstd_compress.c'),
+ join_paths(zstd_rootdir, 'lib/compress/zstd_compress_literals.c'),
+ join_paths(zstd_rootdir, 'lib/compress/zstd_compress_sequences.c'),
+ join_paths(zstd_rootdir, 'lib/compress/zstd_compress_superblock.c'),
+ join_paths(zstd_rootdir, 'lib/compress/zstdmt_compress.c'),
+ join_paths(zstd_rootdir, 'lib/compress/zstd_fast.c'),
+ join_paths(zstd_rootdir, 'lib/compress/zstd_double_fast.c'),
+ join_paths(zstd_rootdir, 'lib/compress/zstd_lazy.c'),
+ join_paths(zstd_rootdir, 'lib/compress/zstd_opt.c'),
+ join_paths(zstd_rootdir, 'lib/compress/zstd_ldm.c'),
+ join_paths(zstd_rootdir, 'lib/decompress/huf_decompress.c'),
+ join_paths(zstd_rootdir, 'lib/decompress/zstd_decompress.c'),
+ join_paths(zstd_rootdir, 'lib/decompress/zstd_decompress_block.c'),
+ join_paths(zstd_rootdir, 'lib/decompress/zstd_ddict.c'),
+ join_paths(zstd_rootdir, 'lib/dictBuilder/cover.c'),
+ join_paths(zstd_rootdir, 'lib/dictBuilder/fastcover.c'),
+ join_paths(zstd_rootdir, 'lib/dictBuilder/divsufsort.c'),
+ join_paths(zstd_rootdir, 'lib/dictBuilder/zdict.c'),
+ join_paths(zstd_rootdir, 'lib/deprecated/zbuff_common.c'),
+ join_paths(zstd_rootdir, 'lib/deprecated/zbuff_compress.c'),
+ join_paths(zstd_rootdir, 'lib/deprecated/zbuff_decompress.c')]
+
+# Explicit define legacy support
+add_project_arguments('-DZSTD_LEGACY_SUPPORT=@0@'.format(legacy_level),
+ language: 'c')
+
+if legacy_level == 0
+ message('Legacy support: DISABLED')
+else
+ # See ZSTD_LEGACY_SUPPORT of lib/README.md
+ message('Enable legacy support back to version 0.@0@'.format(legacy_level))
+
+ libzstd_includes += [ include_directories(join_paths(zstd_rootdir, 'lib/legacy')) ]
+ foreach i : [1, 2, 3, 4, 5, 6, 7]
+ if legacy_level <= i
+ libzstd_sources += join_paths(zstd_rootdir, 'lib/legacy/zstd_v0@0@.c'.format(i))
+ endif
+ endforeach
+endif
+
+libzstd_deps = []
+if use_multi_thread
+ message('Enable multi-threading support')
+ add_project_arguments('-DZSTD_MULTITHREAD', language: 'c')
+ libzstd_deps = [ thread_dep ]
+endif
+
+libzstd_c_args = []
+if cc_id == compiler_msvc
+ if default_library_type != 'static'
+ libzstd_sources += [windows_mod.compile_resources(
+ join_paths(zstd_rootdir, 'build/VS2010/libzstd-dll/libzstd-dll.rc'))]
+ libzstd_c_args += ['-DZSTD_DLL_EXPORT=1',
+ '-DZSTD_HEAPMODE=0',
+ '-D_CONSOLE',
+ '-D_CRT_SECURE_NO_WARNINGS']
+ else
+ libzstd_c_args += ['-DZSTD_HEAPMODE=0',
+ '-D_CRT_SECURE_NO_WARNINGS']
+ endif
+endif
+
+mingw_ansi_stdio_flags = []
+if host_machine_os == os_windows and cc_id == compiler_gcc
+ mingw_ansi_stdio_flags = [ '-D__USE_MINGW_ANSI_STDIO' ]
+endif
+libzstd_c_args += mingw_ansi_stdio_flags
+
+libzstd_debug_cflags = []
+if use_debug
+ libzstd_c_args += '-DDEBUGLEVEL=@0@'.format(debug_level)
+ if cc_id == compiler_gcc or cc_id == compiler_clang
+ libzstd_debug_cflags = ['-Wstrict-aliasing=1', '-Wswitch-enum',
+ '-Wdeclaration-after-statement', '-Wstrict-prototypes',
+ '-Wundef', '-Wpointer-arith', '-Wvla',
+ '-Wformat=2', '-Winit-self', '-Wfloat-equal', '-Wwrite-strings',
+ '-Wredundant-decls', '-Wmissing-prototypes', '-Wc++-compat']
+ endif
+endif
+libzstd_c_args += cc.get_supported_arguments(libzstd_debug_cflags)
+
+libzstd = library('zstd',
+ libzstd_sources,
+ include_directories: libzstd_includes,
+ c_args: libzstd_c_args,
+ dependencies: libzstd_deps,
+ install: true,
+ version: zstd_libversion)
+
+libzstd_dep = declare_dependency(link_with: libzstd,
+ include_directories: libzstd_includes)
+
+pkgconfig.generate(libzstd,
+ name: 'libzstd',
+ filebase: 'libzstd',
+ description: 'fast lossless compression algorithm library',
+ version: zstd_libversion,
+ url: 'http://www.zstd.net/')
+
+install_headers(join_paths(zstd_rootdir, 'lib/zstd.h'),
+ join_paths(zstd_rootdir, 'lib/deprecated/zbuff.h'),
+ join_paths(zstd_rootdir, 'lib/dictBuilder/zdict.h'),
+ join_paths(zstd_rootdir, 'lib/common/zstd_errors.h'))
diff --git a/src/zstd/build/meson/meson.build b/src/zstd/build/meson/meson.build
new file mode 100644
index 000000000..970cf3c92
--- /dev/null
+++ b/src/zstd/build/meson/meson.build
@@ -0,0 +1,147 @@
+# #############################################################################
+# Copyright (c) 2018-present Dima Krasner <dima@dimakrasner.com>
+# lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+project('zstd',
+ ['c', 'cpp'],
+ license: ['BSD', 'GPLv2'],
+ default_options : [
+ 'c_std=gnu99',
+ 'cpp_std=c++11',
+ 'buildtype=release'
+ ],
+ version: 'DUMMY',
+ meson_version: '>=0.47.0')
+
+cc = meson.get_compiler('c')
+cxx = meson.get_compiler('cpp')
+pkgconfig = import('pkgconfig')
+python3 = import('python').find_installation()
+windows_mod = import('windows')
+
+host_machine_os = host_machine.system()
+os_windows = 'windows'
+os_linux = 'linux'
+os_darwin = 'darwin'
+os_freebsd = 'freebsd'
+os_sun = 'sunos'
+
+cc_id = cc.get_id()
+compiler_gcc = 'gcc'
+compiler_clang = 'clang'
+compiler_msvc = 'msvc'
+
+zstd_version = meson.project_version()
+
+zstd_h_file = join_paths(meson.current_source_dir(), '../../lib/zstd.h')
+GetZstdLibraryVersion_py = files('GetZstdLibraryVersion.py')
+r = run_command(python3, GetZstdLibraryVersion_py, zstd_h_file)
+if r.returncode() == 0
+ zstd_version = r.stdout().strip()
+ message('Project version is now: @0@'.format(zstd_version))
+else
+ error('Cannot find project version in @0@'.format(zstd_h_file))
+endif
+
+zstd_libversion = zstd_version
+
+# =============================================================================
+# Installation directories
+# =============================================================================
+
+zstd_prefix = get_option('prefix')
+zstd_bindir = get_option('bindir')
+zstd_datadir = get_option('datadir')
+zstd_mandir = get_option('mandir')
+zstd_docdir = join_paths(zstd_datadir, 'doc', meson.project_name())
+
+# =============================================================================
+# Project options
+# =============================================================================
+
+# Built-in options
+use_debug = get_option('debug')
+buildtype = get_option('buildtype')
+default_library_type = get_option('default_library')
+
+# Custom options
+debug_level = get_option('debug_level')
+legacy_level = get_option('legacy_level')
+use_backtrace = get_option('backtrace')
+use_static_runtime = get_option('static_runtime')
+
+bin_programs = get_option('bin_programs')
+bin_contrib = get_option('bin_contrib')
+bin_tests = get_option('bin_tests')
+
+feature_multi_thread = get_option('multi_thread')
+feature_zlib = get_option('zlib')
+feature_lzma = get_option('lzma')
+feature_lz4 = get_option('lz4')
+
+# =============================================================================
+# Dependencies
+# =============================================================================
+
+libm_dep = cc.find_library('m', required: bin_tests)
+thread_dep = dependency('threads', required: feature_multi_thread)
+use_multi_thread = thread_dep.found()
+# Arguments in dependency should be equivalent to those passed to pkg-config
+zlib_dep = dependency('zlib', required: feature_zlib)
+use_zlib = zlib_dep.found()
+lzma_dep = dependency('liblzma', required: feature_lzma)
+use_lzma = lzma_dep.found()
+lz4_dep = dependency('liblz4', required: feature_lz4)
+use_lz4 = lz4_dep.found()
+
+# =============================================================================
+# Compiler flags
+# =============================================================================
+
+add_project_arguments('-DXXH_NAMESPACE=ZSTD_', language: ['c'])
+
+if [compiler_gcc, compiler_clang].contains(cc_id)
+ common_warning_flags = [ '-Wextra', '-Wundef', '-Wshadow', '-Wcast-align', '-Wcast-qual' ]
+ if cc_id == compiler_clang
+ # Should use Meson's own --werror build option
+ #common_warning_flags += '-Werror'
+ common_warning_flags += ['-Wconversion', '-Wno-sign-conversion', '-Wdocumentation']
+ endif
+ cc_compile_flags = cc.get_supported_arguments(common_warning_flags + ['-Wstrict-prototypes'])
+ cxx_compile_flags = cxx.get_supported_arguments(common_warning_flags)
+ add_project_arguments(cc_compile_flags, language : 'c')
+ add_project_arguments(cxx_compile_flags, language : 'cpp')
+elif cc_id == compiler_msvc
+ msvc_compile_flags = [ '/D_UNICODE', '/DUNICODE' ]
+ if use_multi_thread
+ msvc_compile_flags += '/MP'
+ endif
+ if use_static_runtime
+ msvc_compile_flags += '/MT'
+ endif
+ add_project_arguments(msvc_compile_flags, language: ['c', 'cpp'])
+endif
+
+# =============================================================================
+# Subdirs
+# =============================================================================
+
+subdir('lib')
+
+if bin_programs
+ subdir('programs')
+endif
+
+if bin_tests
+ subdir('tests')
+endif
+
+if bin_contrib
+ subdir('contrib')
+endif
diff --git a/src/zstd/build/meson/meson_options.txt b/src/zstd/build/meson/meson_options.txt
new file mode 100644
index 000000000..90a81c539
--- /dev/null
+++ b/src/zstd/build/meson/meson_options.txt
@@ -0,0 +1,36 @@
+# #############################################################################
+# Copyright (c) 2018-present Dima Krasner <dima@dimakrasner.com>
+# lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+# Read guidelines from https://wiki.gnome.org/Initiatives/GnomeGoals/MesonPorting
+
+option('legacy_level', type: 'integer', min: 0, max: 7, value: '5',
+ description: 'Support any legacy format: 7 to 1 for v0.7+ to v0.1+')
+option('debug_level', type: 'integer', min: 0, max: 9, value: 1,
+ description: 'Enable run-time debug. See lib/common/debug.h')
+option('backtrace', type: 'boolean', value: false,
+ description: 'Display a stack backtrace when execution generates a runtime exception')
+option('static_runtime', type: 'boolean', value: false,
+ description: 'Link to static run-time libraries on MSVC')
+
+option('bin_programs', type: 'boolean', value: true,
+ description: 'Enable programs build')
+option('bin_tests', type: 'boolean', value: false,
+ description: 'Enable tests build')
+option('bin_contrib', type: 'boolean', value: false,
+ description: 'Enable contrib build')
+
+option('multi_thread', type: 'feature', value: 'enabled',
+ description: 'Enable multi-threading when pthread is detected')
+option('zlib', type: 'feature', value: 'auto',
+ description: 'Enable zlib support')
+option('lzma', type: 'feature', value: 'auto',
+ description: 'Enable lzma support')
+option('lz4', type: 'feature', value: 'auto',
+ description: 'Enable lz4 support')
diff --git a/src/zstd/build/meson/programs/meson.build b/src/zstd/build/meson/programs/meson.build
new file mode 100644
index 000000000..363818f9d
--- /dev/null
+++ b/src/zstd/build/meson/programs/meson.build
@@ -0,0 +1,104 @@
+# #############################################################################
+# Copyright (c) 2018-present Dima Krasner <dima@dimakrasner.com>
+# lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+zstd_rootdir = '../../..'
+
+zstd_programs_sources = [join_paths(zstd_rootdir, 'programs/zstdcli.c'),
+ join_paths(zstd_rootdir, 'programs/util.c'),
+ join_paths(zstd_rootdir, 'programs/timefn.c'),
+ join_paths(zstd_rootdir, 'programs/fileio.c'),
+ join_paths(zstd_rootdir, 'programs/benchfn.c'),
+ join_paths(zstd_rootdir, 'programs/benchzstd.c'),
+ join_paths(zstd_rootdir, 'programs/datagen.c'),
+ join_paths(zstd_rootdir, 'programs/dibio.c')]
+
+zstd_c_args = libzstd_debug_cflags
+if use_multi_thread
+ zstd_c_args += [ '-DZSTD_MULTITHREAD' ]
+endif
+
+zstd_deps = [ libzstd_dep ]
+if use_zlib
+ zstd_deps += [ zlib_dep ]
+ zstd_c_args += [ '-DZSTD_GZCOMPRESS', '-DZSTD_GZDECOMPRESS' ]
+endif
+
+if use_lzma
+ zstd_deps += [ lzma_dep ]
+ zstd_c_args += [ '-DZSTD_LZMACOMPRESS', '-DZSTD_LZMADECOMPRESS' ]
+endif
+
+if use_lz4
+ zstd_deps += [ lz4_dep ]
+ zstd_c_args += [ '-DZSTD_LZ4COMPRESS', '-DZSTD_LZ4DECOMPRESS' ]
+endif
+
+export_dynamic_on_windows = false
+# explicit backtrace enable/disable for Linux & Darwin
+if not use_backtrace
+ zstd_c_args += '-DBACKTRACE_ENABLE=0'
+elif use_debug and host_machine_os == os_windows # MinGW target
+ zstd_c_args += '-DBACKTRACE_ENABLE=1'
+ export_dynamic_on_windows = true
+endif
+
+if cc_id == compiler_msvc
+ if default_library_type != 'static'
+ zstd_programs_sources += [windows_mod.compile_resources(
+ join_paths(zstd_rootdir, 'build/VS2010/zstd/zstd.rc'))]
+ endif
+endif
+
+zstd = executable('zstd',
+ zstd_programs_sources,
+ c_args: zstd_c_args,
+ dependencies: zstd_deps,
+ export_dynamic: export_dynamic_on_windows, # Since Meson 0.45.0
+ install: true)
+
+zstd_frugal_sources = [join_paths(zstd_rootdir, 'programs/zstdcli.c'),
+ join_paths(zstd_rootdir, 'programs/timefn.c'),
+ join_paths(zstd_rootdir, 'programs/util.c'),
+ join_paths(zstd_rootdir, 'programs/fileio.c')]
+
+# Minimal target, with only zstd compression and decompression.
+# No bench. No legacy.
+executable('zstd-frugal',
+ zstd_frugal_sources,
+ dependencies: libzstd_dep,
+ c_args: [ '-DZSTD_NOBENCH', '-DZSTD_NODICT' ],
+ install: true)
+
+install_data(join_paths(zstd_rootdir, 'programs/zstdgrep'),
+ join_paths(zstd_rootdir, 'programs/zstdless'),
+ install_dir: zstd_bindir)
+
+# =============================================================================
+# Programs and manpages installing
+# =============================================================================
+
+install_man(join_paths(zstd_rootdir, 'programs/zstd.1'),
+ join_paths(zstd_rootdir, 'programs/zstdgrep.1'),
+ join_paths(zstd_rootdir, 'programs/zstdless.1'))
+
+InstallSymlink_py = '../InstallSymlink.py'
+zstd_man1_dir = join_paths(zstd_mandir, 'man1')
+bin_EXT = host_machine_os == os_windows ? '.exe' : ''
+man1_EXT = meson.version().version_compare('>=0.49.0') ? '.1' : '.1.gz'
+
+foreach f : ['zstdcat', 'unzstd']
+ meson.add_install_script(InstallSymlink_py, 'zstd' + bin_EXT, f + bin_EXT, zstd_bindir)
+ meson.add_install_script(InstallSymlink_py, 'zstd' + man1_EXT, f + man1_EXT, zstd_man1_dir)
+endforeach
+
+if use_multi_thread
+ meson.add_install_script(InstallSymlink_py, 'zstd' + bin_EXT, 'zstdmt' + bin_EXT, zstd_bindir)
+ meson.add_install_script(InstallSymlink_py, 'zstd' + man1_EXT, 'zstdmt' + man1_EXT, zstd_man1_dir)
+endif
diff --git a/src/zstd/build/meson/tests/meson.build b/src/zstd/build/meson/tests/meson.build
new file mode 100644
index 000000000..0587f9a70
--- /dev/null
+++ b/src/zstd/build/meson/tests/meson.build
@@ -0,0 +1,206 @@
+# #############################################################################
+# Copyright (c) 2018-present Dima Krasner <dima@dimakrasner.com>
+# lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+
+zstd_rootdir = '../../..'
+
+tests_supported_oses = [os_linux, 'gnu/kfreebsd', os_darwin, 'gnu', 'openbsd',
+ os_freebsd, 'netbsd', 'dragonfly', os_sun]
+
+# =============================================================================
+# Test flags
+# =============================================================================
+
+FUZZER_FLAGS = ['--no-big-tests']
+FUZZERTEST = '-T200s'
+ZSTREAM_TESTTIME = '-T90s'
+DECODECORPUS_TESTTIME = '-T30'
+ZSTDRTTEST = ['--test-large-data']
+
+# =============================================================================
+# Executables
+# =============================================================================
+
+test_includes = [ include_directories(join_paths(zstd_rootdir, 'programs')) ]
+
+datagen_sources = [join_paths(zstd_rootdir, 'programs/datagen.c'),
+ join_paths(zstd_rootdir, 'tests/datagencli.c')]
+datagen = executable('datagen',
+ datagen_sources,
+ c_args: [ '-DNDEBUG' ],
+ include_directories: test_includes,
+ dependencies: libzstd_dep,
+ install: false)
+
+fullbench_sources = [join_paths(zstd_rootdir, 'programs/datagen.c'),
+ join_paths(zstd_rootdir, 'programs/util.c'),
+ join_paths(zstd_rootdir, 'programs/timefn.c'),
+ join_paths(zstd_rootdir, 'programs/benchfn.c'),
+ join_paths(zstd_rootdir, 'programs/benchzstd.c'),
+ join_paths(zstd_rootdir, 'tests/fullbench.c')]
+fullbench = executable('fullbench',
+ fullbench_sources,
+ include_directories: test_includes,
+ dependencies: libzstd_dep,
+ install: false)
+
+fuzzer_sources = [join_paths(zstd_rootdir, 'programs/datagen.c'),
+ join_paths(zstd_rootdir, 'programs/util.c'),
+ join_paths(zstd_rootdir, 'programs/timefn.c'),
+ join_paths(zstd_rootdir, 'tests/fuzzer.c')]
+fuzzer = executable('fuzzer',
+ fuzzer_sources,
+ include_directories: test_includes,
+ dependencies: libzstd_dep,
+ install: false)
+
+zstreamtest_sources = [join_paths(zstd_rootdir, 'programs/datagen.c'),
+ join_paths(zstd_rootdir, 'programs/util.c'),
+ join_paths(zstd_rootdir, 'programs/timefn.c'),
+ join_paths(zstd_rootdir, 'tests/seqgen.c'),
+ join_paths(zstd_rootdir, 'tests/zstreamtest.c')]
+zstreamtest = executable('zstreamtest',
+ zstreamtest_sources,
+ include_directories: test_includes,
+ dependencies: libzstd_dep,
+ install: false)
+
+paramgrill_sources = [join_paths(zstd_rootdir, 'programs/benchfn.c'),
+ join_paths(zstd_rootdir, 'programs/timefn.c'),
+ join_paths(zstd_rootdir, 'programs/benchzstd.c'),
+ join_paths(zstd_rootdir, 'programs/datagen.c'),
+ join_paths(zstd_rootdir, 'programs/util.c'),
+ join_paths(zstd_rootdir, 'tests/paramgrill.c')]
+paramgrill = executable('paramgrill',
+ paramgrill_sources,
+ include_directories: test_includes,
+ dependencies: [ libzstd_dep, libm_dep ],
+ install: false)
+
+roundTripCrash_sources = [join_paths(zstd_rootdir, 'tests/roundTripCrash.c')]
+roundTripCrash = executable('roundTripCrash',
+ roundTripCrash_sources,
+ dependencies: [ libzstd_dep ],
+ install: false)
+
+longmatch_sources = [join_paths(zstd_rootdir, 'tests/longmatch.c')]
+longmatch = executable('longmatch',
+ longmatch_sources,
+ dependencies: [ libzstd_dep ],
+ install: false)
+
+invalidDictionaries_sources = [join_paths(zstd_rootdir, 'tests/invalidDictionaries.c')]
+invalidDictionaries = executable('invalidDictionaries',
+ invalidDictionaries_sources,
+ dependencies: [ libzstd_dep ],
+ install: false)
+
+if 0 < legacy_level and legacy_level <= 4
+ legacy_sources = [join_paths(zstd_rootdir, 'tests/legacy.c')]
+ legacy = executable('legacy',
+ legacy_sources,
+ # Use -Dlegacy_level build option to control it
+ #c_args: '-DZSTD_LEGACY_SUPPORT=4',
+ dependencies: [ libzstd_dep ],
+ install: false)
+endif
+
+decodecorpus_sources = [join_paths(zstd_rootdir, 'programs/util.c'),
+ join_paths(zstd_rootdir, 'programs/timefn.c'),
+ join_paths(zstd_rootdir, 'tests/decodecorpus.c')]
+decodecorpus = executable('decodecorpus',
+ decodecorpus_sources,
+ include_directories: test_includes,
+ dependencies: [ libzstd_dep, libm_dep ],
+ install: false)
+
+poolTests_sources = [join_paths(zstd_rootdir, 'programs/util.c'),
+ join_paths(zstd_rootdir, 'programs/timefn.c'),
+ join_paths(zstd_rootdir, 'tests/poolTests.c'),
+ join_paths(zstd_rootdir, 'lib/common/pool.c'),
+ join_paths(zstd_rootdir, 'lib/common/threading.c'),
+ join_paths(zstd_rootdir, 'lib/common/zstd_common.c'),
+ join_paths(zstd_rootdir, 'lib/common/error_private.c')]
+poolTests = executable('poolTests',
+ poolTests_sources,
+ include_directories: test_includes,
+ dependencies: [ libzstd_dep, thread_dep ],
+ install: false)
+
+checkTag_sources = [join_paths(zstd_rootdir, 'tests/checkTag.c')]
+checkTag = executable('checkTag',
+ checkTag_sources,
+ dependencies: [ libzstd_dep ],
+ install: false)
+
+# =============================================================================
+# Tests (Use "meson test --list" to list all tests)
+# =============================================================================
+
+if tests_supported_oses.contains(host_machine_os)
+ valgrind_prog = find_program('valgrind', ['/usr/bin/valgrind'], required: true)
+ valgrindTest_py = files('valgrindTest.py')
+ test('valgrindTest',
+ valgrindTest_py,
+ args: [valgrind_prog.path(), zstd, datagen, fuzzer, fullbench],
+ depends: [zstd, datagen, fuzzer, fullbench],
+ timeout: 600) # Timeout should work on HDD drive
+endif
+
+if host_machine_os != os_windows
+ playTests_sh = find_program(join_paths(zstd_rootdir, 'tests/playTests.sh'), required: true)
+ test('test-zstd',
+ playTests_sh,
+ args: ZSTDRTTEST,
+ env: ['ZSTD_BIN=' + zstd.full_path(), 'DATAGEN_BIN=./datagen'],
+ depends: [datagen],
+ workdir: meson.current_build_dir(),
+ timeout: 2800) # Timeout should work on HDD drive
+endif
+
+test('test-fullbench-1',
+ fullbench,
+ args: ['-i1'],
+ depends: [datagen],
+ timeout: 60)
+test('test-fullbench-2',
+ fullbench,
+ args: ['-i1', '-P0'],
+ depends: [datagen],
+ timeout: 60)
+
+if use_zlib
+ test('test-fuzzer',
+ fuzzer,
+ args: ['-v', FUZZERTEST] + FUZZER_FLAGS,
+ timeout: 480)
+endif
+
+test('test-zstream-1',
+ zstreamtest,
+ args: ['-v', ZSTREAM_TESTTIME] + FUZZER_FLAGS,
+ timeout: 240)
+test('test-zstream-2',
+ zstreamtest,
+ args: ['-mt', '-t1', ZSTREAM_TESTTIME] + FUZZER_FLAGS,
+ timeout: 120)
+test('test-zstream-3',
+ zstreamtest,
+ args: ['--newapi', '-t1', ZSTREAM_TESTTIME] + FUZZER_FLAGS,
+ timeout: 120)
+test('test-longmatch', longmatch, timeout: 36)
+test('test-invalidDictionaries', invalidDictionaries) # should be fast
+if 0 < legacy_level and legacy_level <= 4
+ test('test-legacy', legacy) # should be fast
+endif
+test('test-decodecorpus',
+ decodecorpus,
+ args: ['-t', DECODECORPUS_TESTTIME],
+ timeout: 60)
+test('test-poolTests', poolTests) # should be fast
diff --git a/src/zstd/build/meson/tests/valgrindTest.py b/src/zstd/build/meson/tests/valgrindTest.py
new file mode 100644
index 000000000..218f7458b
--- /dev/null
+++ b/src/zstd/build/meson/tests/valgrindTest.py
@@ -0,0 +1,90 @@
+#!/usr/bin/env python3
+# #############################################################################
+# Copyright (c) 2018-present lzutao <taolzu(at)gmail.com>
+# All rights reserved.
+#
+# This source code is licensed under both the BSD-style license (found in the
+# LICENSE file in the root directory of this source tree) and the GPLv2 (found
+# in the COPYING file in the root directory of this source tree).
+# #############################################################################
+import os
+import subprocess
+import tempfile
+
+
+def valgrindTest(valgrind, datagen, fuzzer, zstd, fullbench):
+ VALGRIND_ARGS = [valgrind, '--leak-check=full', '--show-leak-kinds=all', '--error-exitcode=1']
+
+ print('\n ---- valgrind tests : memory analyzer ----')
+
+ subprocess.check_call([*VALGRIND_ARGS, datagen, '-g50M'], stdout=subprocess.DEVNULL)
+
+ if subprocess.call([*VALGRIND_ARGS, zstd],
+ stdout=subprocess.DEVNULL) == 0:
+ raise subprocess.CalledProcessError('zstd without argument should have failed')
+
+ with subprocess.Popen([datagen, '-g80'], stdout=subprocess.PIPE) as p1, \
+ subprocess.Popen([*VALGRIND_ARGS, zstd, '-', '-c'],
+ stdin=p1.stdout,
+ stdout=subprocess.DEVNULL) as p2:
+ p1.stdout.close() # Allow p1 to receive a SIGPIPE if p2 exits.
+ p2.communicate()
+ if p2.returncode != 0:
+ raise subprocess.CalledProcessError()
+
+ with subprocess.Popen([datagen, '-g16KB'], stdout=subprocess.PIPE) as p1, \
+ subprocess.Popen([*VALGRIND_ARGS, zstd, '-vf', '-', '-c'],
+ stdin=p1.stdout,
+ stdout=subprocess.DEVNULL) as p2:
+ p1.stdout.close()
+ p2.communicate()
+ if p2.returncode != 0:
+ raise subprocess.CalledProcessError()
+
+ with tempfile.NamedTemporaryFile() as tmp_fd:
+ with subprocess.Popen([datagen, '-g2930KB'], stdout=subprocess.PIPE) as p1, \
+ subprocess.Popen([*VALGRIND_ARGS, zstd, '-5', '-vf', '-', '-o', tmp_fd.name],
+ stdin=p1.stdout) as p2:
+ p1.stdout.close()
+ p2.communicate()
+ if p2.returncode != 0:
+ raise subprocess.CalledProcessError()
+
+ subprocess.check_call([*VALGRIND_ARGS, zstd, '-vdf', tmp_fd.name, '-c'],
+ stdout=subprocess.DEVNULL)
+
+ with subprocess.Popen([datagen, '-g64MB'], stdout=subprocess.PIPE) as p1, \
+ subprocess.Popen([*VALGRIND_ARGS, zstd, '-vf', '-', '-c'],
+ stdin=p1.stdout,
+ stdout=subprocess.DEVNULL) as p2:
+ p1.stdout.close()
+ p2.communicate()
+ if p2.returncode != 0:
+ raise subprocess.CalledProcessError()
+
+ subprocess.check_call([*VALGRIND_ARGS, fuzzer, '-T1mn', '-t1'])
+ subprocess.check_call([*VALGRIND_ARGS, fullbench, '-i1'])
+
+
+def main():
+ import argparse
+ parser = argparse.ArgumentParser(description='Valgrind tests : memory analyzer')
+ parser.add_argument('valgrind', help='valgrind path')
+ parser.add_argument('zstd', help='zstd path')
+ parser.add_argument('datagen', help='datagen path')
+ parser.add_argument('fuzzer', help='fuzzer path')
+ parser.add_argument('fullbench', help='fullbench path')
+
+ args = parser.parse_args()
+
+ valgrind = args.valgrind
+ zstd = args.zstd
+ datagen = args.datagen
+ fuzzer = args.fuzzer
+ fullbench = args.fullbench
+
+ valgrindTest(valgrind, datagen, fuzzer, zstd, fullbench)
+
+
+if __name__ == '__main__':
+ main()