summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:53:53 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:53:53 +0000
commit8bfec411659061418969c246436a22ade44ff446 (patch)
tree68371d63fe05049a558f5e41d9b9f45b76014aa9 /debian/rules
parentAdding upstream version 2.23.4+deb12u1. (diff)
downloaddevscripts-8bfec411659061418969c246436a22ade44ff446.tar.xz
devscripts-8bfec411659061418969c246436a22ade44ff446.zip
Adding debian version 2.23.4+deb12u1.debian/2.23.4+deb12u1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..26c5c34
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+UBU_SUGGESTS=debian-keyring, equivs, liblwp-protocol-https-perl, libsoap-lite-perl, pristine-tar
+ifeq ($(shell dpkg-vendor --derives-from Ubuntu && echo ubuntu),ubuntu)
+ SUBSTVARS=-V'vendor:Suggests=$(UBU_SUGGESTS)' -V'vendor:Recommends='
+else
+ SUBSTVARS=-V'vendor:Suggests=' -V'vendor:Recommends=$(UBU_SUGGESTS)'
+endif
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@
+
+override_dh_gencontrol:
+ dh_gencontrol -- $(SUBSTVARS) \
+ -V"devscripts:LongDesc=$$(cat README | awk '/^- annotate-output/,/^ exim script for sorting/' | sed -e '/^[[:space:]]*$$/d' -e 's/^/ /g')"