summaryrefslogtreecommitdiffstats
path: root/scripts/mk/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /scripts/mk/Makefile.am
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripts/mk/Makefile.am')
-rw-r--r--scripts/mk/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/scripts/mk/Makefile.am b/scripts/mk/Makefile.am
new file mode 100644
index 0000000..a82e409
--- /dev/null
+++ b/scripts/mk/Makefile.am
@@ -0,0 +1,27 @@
+## Process this file with automake to produce Makefile.in
+
+dist_pkgdata_DATA = \
+ architecture.mk \
+ buildflags.mk \
+ buildopts.mk \
+ buildtools.mk \
+ default.mk \
+ pkg-info.mk \
+ vendor.mk \
+ # EOL
+
+SUFFIXES =
+
+include $(top_srcdir)/build-aux/subst.am
+
+# Ideally we'd use '$(SED) -i', but unfortunately that's not portable.
+install-data-hook:
+ $(do_make_subst) <$(DESTDIR)$(pkgdatadir)/default.mk \
+ >$(DESTDIR)$(pkgdatadir)/default.mk.new
+ mv $(DESTDIR)$(pkgdatadir)/default.mk.new \
+ $(DESTDIR)$(pkgdatadir)/default.mk
+
+ $(do_make_subst) <$(DESTDIR)$(pkgdatadir)/buildtools.mk \
+ >$(DESTDIR)$(pkgdatadir)/buildtools.mk.new
+ mv $(DESTDIR)$(pkgdatadir)/buildtools.mk.new \
+ $(DESTDIR)$(pkgdatadir)/buildtools.mk