summaryrefslogtreecommitdiffstats
path: root/tests/t-buildinfo/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-buildinfo/Makefile
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-buildinfo/Makefile')
-rw-r--r--tests/t-buildinfo/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/t-buildinfo/Makefile b/tests/t-buildinfo/Makefile
new file mode 100644
index 0000000..019d850
--- /dev/null
+++ b/tests/t-buildinfo/Makefile
@@ -0,0 +1,11 @@
+OPTS = --admindir=$(CURDIR)/db-buildinfo
+
+test:
+ touch test-binary-a_1.0_amd64.deb
+ dpkg-source -b pkg-source
+ cd pkg-source && DEB_HOST_ARCH=amd64 dpkg-checkbuilddeps $(OPTS)
+ cd pkg-source && DEB_HOST_ARCH=amd64 dpkg-genbuildinfo $(OPTS)
+
+test-clean:
+ rm -f *.dsc *.deb *.buildinfo
+ rm -f *.tar.xz