summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-normal/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-conffile-normal/Makefile
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-conffile-normal/Makefile')
-rw-r--r--tests/t-conffile-normal/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/t-conffile-normal/Makefile b/tests/t-conffile-normal/Makefile
new file mode 100644
index 0000000..52f29c7
--- /dev/null
+++ b/tests/t-conffile-normal/Makefile
@@ -0,0 +1,15 @@
+TESTS_DEB := pkg-conffile
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-conffile.deb
+ test -f "$(DPKG_INSTDIR)/test-dir/test-conffile"
+ $(DPKG_REMOVE) pkg-conffile
+ $(DPKG_PURGE) pkg-conffile
+ test ! -f "$(DPKG_INSTDIR)/test-dir/test-conffile"
+ test ! -d "$(DPKG_INSTDIR)/test-dir"
+
+test-clean:
+ $(DPKG_PURGE) pkg-conffile
+ $(BEROOT) $(RM) -rf "$(DPKG_INSTDIR)/test-dir"