summaryrefslogtreecommitdiffstats
path: root/tests/t-control-no-arch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-control-no-arch
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-control-no-arch')
-rw-r--r--tests/t-control-no-arch/Makefile22
-rw-r--r--tests/t-control-no-arch/pkg-no-arch/DEBIAN/control6
2 files changed, 28 insertions, 0 deletions
diff --git a/tests/t-control-no-arch/Makefile b/tests/t-control-no-arch/Makefile
new file mode 100644
index 0000000..48b79fd
--- /dev/null
+++ b/tests/t-control-no-arch/Makefile
@@ -0,0 +1,22 @@
+include ../Test.mk
+
+test-case:
+ # test building package with missing Architecture field.
+ ! $(DPKG_BUILD_DEB) pkg-no-arch
+
+ # build bogus packages
+ $(DPKG_BUILD_DEB) --nocheck pkg-no-arch
+
+ # test handling of package without the Architecture field
+ ! $(DPKG_INSTALL) pkg-no-arch.deb
+ $(call pkg_is_not_installed,pkg-no-arch)
+ # these ancient/bogus packages need to be forced now
+ $(DPKG_INSTALL) --force-architecture pkg-no-arch.deb
+ $(call pkg_is_installed,pkg-no-arch)
+ ! $(call stdout_has,$(DPKG_QUERY) --status pkg-no-arch,^Architecture:)
+ $(DPKG_PURGE) pkg-no-arch
+ # Clear the available file to avoid missing Architecture warnings
+ $(BEROOT) $(DPKG) --clear-avail
+
+test-clean:
+ rm -f pkg-no-arch.deb
diff --git a/tests/t-control-no-arch/pkg-no-arch/DEBIAN/control b/tests/t-control-no-arch/pkg-no-arch/DEBIAN/control
new file mode 100644
index 0000000..8871216
--- /dev/null
+++ b/tests/t-control-no-arch/pkg-no-arch/DEBIAN/control
@@ -0,0 +1,6 @@
+Package: pkg-no-arch
+Version: 0.0-1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Description: test package - without Architecture field