summaryrefslogtreecommitdiffstats
path: root/tests/t-dir-leftover-deadlock/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-dir-leftover-deadlock/Makefile
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-dir-leftover-deadlock/Makefile')
-rw-r--r--tests/t-dir-leftover-deadlock/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/t-dir-leftover-deadlock/Makefile b/tests/t-dir-leftover-deadlock/Makefile
new file mode 100644
index 0000000..e0f381f
--- /dev/null
+++ b/tests/t-dir-leftover-deadlock/Makefile
@@ -0,0 +1,17 @@
+TESTS_DEB := pkg-dir-shared-0 pkg-dir-shared-1
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-dir-shared-0.deb
+ $(DPKG_INSTALL) pkg-dir-shared-1.deb
+ $(DPKG_REMOVE) pkg-dir-shared-1
+ $(DPKG_REMOVE) pkg-dir-shared-0
+ $(DPKG_PURGE) pkg-dir-shared-0
+ $(DPKG_PURGE) pkg-dir-shared-1
+ test ! -d '$(DPKG_INSTDIR)/test-dir'
+
+test-clean:
+ $(DPKG_PURGE) pkg-dir-shared-0
+ $(DPKG_PURGE) pkg-dir-shared-1
+ $(BEROOT) rm -rf '$(DPKG_INSTDIR)/test-dir'