summaryrefslogtreecommitdiffstats
path: root/tests/t-file-replaces-disappear/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-file-replaces-disappear/Makefile
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-file-replaces-disappear/Makefile')
-rw-r--r--tests/t-file-replaces-disappear/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/tests/t-file-replaces-disappear/Makefile b/tests/t-file-replaces-disappear/Makefile
new file mode 100644
index 0000000..719f02b
--- /dev/null
+++ b/tests/t-file-replaces-disappear/Makefile
@@ -0,0 +1,65 @@
+TESTS_DEB := pkg-file-original pkg-file-takeover
+
+include ../Test.mk
+
+TEST_CASES += test-two-run-ordered
+TEST_CASES += test-one-run-ordered
+TEST_CASES += test-two-run-reverse
+TEST_CASES += test-one-run-reverse
+
+test-case: $(TEST_CASES)
+
+define VERIFY
+$(call pkg_is_installed,pkg-file-takeover)
+test "`$(DPKG_QUERY) -S /test-file`" = "pkg-file-takeover: /test-file"
+test "`$(DPKG_QUERY) -S /test-other`" = "pkg-file-takeover: /test-other"
+cmp ref-file "$(DPKG_INSTDIR)/test-file"
+cmp ref-file "$(DPKG_INSTDIR)/test-other"
+endef
+
+test-two-run-ordered:
+ # test-two-run-ordered
+ $(DPKG_INSTALL) pkg-file-original.deb
+ $(DPKG_INSTALL) pkg-file-takeover.deb
+ $(call pkg_is_not_installed,pkg-file-original)
+ $(VERIFY)
+ $(DPKG_PURGE) pkg-file-original pkg-file-takeover
+ test ! -f "$(DPKG_INSTDIR)/test-file"
+ test ! -f "$(DPKG_INSTDIR)/test-other"
+
+test-one-run-ordered:
+ # test-one-run-ordered
+ $(DPKG_INSTALL) pkg-file-original.deb pkg-file-takeover.deb
+ $(call pkg_is_not_installed,pkg-file-original)
+ $(VERIFY)
+ $(DPKG_PURGE) pkg-file-original pkg-file-takeover
+ test ! -f "$(DPKG_INSTDIR)/test-file"
+ test ! -f "$(DPKG_INSTDIR)/test-other"
+
+test-two-run-reverse:
+ # test-two-run-reverse
+ $(DPKG_INSTALL) pkg-file-takeover.deb
+ $(DPKG_INSTALL) pkg-file-original.deb
+ $(call pkg_is_installed,pkg-file-original)
+ $(VERIFY)
+ $(DPKG_PURGE) pkg-file-original
+ test -f "$(DPKG_INSTDIR)/test-file"
+ test -f "$(DPKG_INSTDIR)/test-other"
+ $(DPKG_PURGE) pkg-file-takeover
+ test ! -f "$(DPKG_INSTDIR)/test-file"
+ test ! -f "$(DPKG_INSTDIR)/test-other"
+
+test-one-run-reverse:
+ # test-one-run-reverse
+ $(DPKG_INSTALL) pkg-file-takeover.deb pkg-file-original.deb
+ $(call pkg_is_installed,pkg-file-original)
+ $(VERIFY)
+ $(DPKG_PURGE) pkg-file-original
+ test -f "$(DPKG_INSTDIR)/test-file"
+ test -f "$(DPKG_INSTDIR)/test-other"
+ $(DPKG_PURGE) pkg-file-takeover
+ test ! -f "$(DPKG_INSTDIR)/test-file"
+ test ! -f "$(DPKG_INSTDIR)/test-other"
+
+test-clean:
+ $(DPKG_PURGE) pkg-file-original pkg-file-takeover