summaryrefslogtreecommitdiffstats
path: root/tests/t-switch-symlink-rel-to-dir/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-switch-symlink-rel-to-dir/Makefile
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-switch-symlink-rel-to-dir/Makefile')
-rw-r--r--tests/t-switch-symlink-rel-to-dir/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/tests/t-switch-symlink-rel-to-dir/Makefile b/tests/t-switch-symlink-rel-to-dir/Makefile
new file mode 100644
index 0000000..ee936a1
--- /dev/null
+++ b/tests/t-switch-symlink-rel-to-dir/Makefile
@@ -0,0 +1,30 @@
+TESTS_DEB := pkg-dir-real pkg-dir-symlink-0 pkg-dir-symlink-1
+
+include ../Test.mk
+
+build-hook:
+ mkdir -p pkg-dir-symlink-0/test-path
+ ln -sf ../test-dir pkg-dir-symlink-0/test-path/test-symlink
+
+clean-hook:
+ $(RM) pkg-dir-symlink-0/test-path/test-symlink
+ -rmdir pkg-dir-symlink-0/test-path
+
+test-case:
+ $(DPKG_INSTALL) pkg-dir-real.deb
+
+ $(DPKG_INSTALL) pkg-dir-symlink-0.deb
+ test -h '$(DPKG_INSTDIR)/test-path/test-symlink'
+
+ $(DPKG_INSTALL) pkg-dir-symlink-1.deb
+ ! test -h '$(DPKG_INSTDIR)/test-path/test-symlink'
+ test -d '$(DPKG_INSTDIR)/test-path/test-symlink'
+
+ $(DPKG_PURGE) pkg-dir-symlink
+ ! test -e '$(DPKG_INSTDIR)/test-path/test-symlink'
+
+ $(DPKG_PURGE) pkg-dir-real
+
+test-clean:
+ $(DPKG_PURGE) pkg-dir-symlink
+ $(DPKG_PURGE) pkg-dir-real