summaryrefslogtreecommitdiffstats
path: root/tests/t-unpack-fifo/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-unpack-fifo/Makefile
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-unpack-fifo/Makefile')
-rw-r--r--tests/t-unpack-fifo/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/t-unpack-fifo/Makefile b/tests/t-unpack-fifo/Makefile
new file mode 100644
index 0000000..eaa848a
--- /dev/null
+++ b/tests/t-unpack-fifo/Makefile
@@ -0,0 +1,22 @@
+PKG := pkg-fifo
+
+TESTS_DEB := pkg-fifo
+
+include ../Test.mk
+
+$(PKG)/test-fifo:
+ mkfifo $@
+
+build-hook: $(PKG)/test-fifo
+
+clean-hook:
+ rm -f $(PKG)/test-fifo
+
+test-case:
+ # test unpacking a fifo
+ $(DPKG_INSTALL) pkg-fifo.deb
+ $(call pkg_is_installed,pkg-fifo)
+
+test-clean:
+ $(DPKG_PURGE) pkg-fifo
+