summaryrefslogtreecommitdiffstats
path: root/tests/t-unpack-symlink/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-unpack-symlink/Makefile
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-unpack-symlink/Makefile')
-rw-r--r--tests/t-unpack-symlink/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/t-unpack-symlink/Makefile b/tests/t-unpack-symlink/Makefile
new file mode 100644
index 0000000..518ca4e
--- /dev/null
+++ b/tests/t-unpack-symlink/Makefile
@@ -0,0 +1,20 @@
+TESTS_DEB := pkg-symlink
+
+include ../Test.mk
+
+build-hook:
+ ln -fs test-file pkg-symlink/test-symlink
+
+clean-hook:
+ $(RM) pkg-symlink/test-symlink
+
+test-case:
+ # test unpacking symlinks
+ $(DPKG_INSTALL) pkg-symlink.deb
+ $(call pkg_is_installed,pkg-symlink)
+ test -f "$(DPKG_INSTDIR)/test-file"
+ test -L "$(DPKG_INSTDIR)/test-symlink"
+ test "`readlink '$(DPKG_INSTDIR)/test-symlink'`" = "test-file"
+
+test-clean:
+ $(DPKG_PURGE) pkg-symlink