summaryrefslogtreecommitdiffstats
path: root/tests/Feature.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Feature.mk')
-rw-r--r--tests/Feature.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/Feature.mk b/tests/Feature.mk
new file mode 100644
index 0000000..da4e8d6
--- /dev/null
+++ b/tests/Feature.mk
@@ -0,0 +1,19 @@
+#
+# Dpkg functional testsuite (kind of)
+#
+# Copyright © 2015 Guillem Jover <guillem@debian.org>
+#
+
+## Feature checks setup ##
+
+ifneq ($(DPKG_FEATURE_CHECKS),yes)
+export DPKG_FEATURE_CHECKS := yes
+
+# XXX: once apt is fixed:
+#export DPKG_HAS_CONFIGURE_WITH_IMPLICIT_TRIGGER_PENDING ?= 1
+
+ifneq (,$(filter as-root,$(DPKG_TESTSUITE_OPTIONS)))
+export DPKG_AS_ROOT = 1
+endif
+
+endif