summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-forcenew/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-conffile-forcenew/Makefile')
-rw-r--r--tests/t-conffile-forcenew/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/t-conffile-forcenew/Makefile b/tests/t-conffile-forcenew/Makefile
new file mode 100644
index 0000000..c492c6c
--- /dev/null
+++ b/tests/t-conffile-forcenew/Makefile
@@ -0,0 +1,17 @@
+TESTS_DEB := pkg-conff-forcenew-0 pkg-conff-forcenew-1
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-conff-forcenew-0.deb
+ # Modify the conffile.
+ $(BEROOT) cp mod-conffile "$(DPKG_INSTDIR)/test-conffile"
+ # Test that we do not get the new conffile.
+ $(DPKG_INSTALL) pkg-conff-forcenew-0.deb
+ cmp mod-conffile "$(DPKG_INSTDIR)/test-conffile"
+ # Test that we get the new conffile.
+ $(DPKG_INSTALL) --force-confnew pkg-conff-forcenew-1.deb
+ cmp ref-conffile "$(DPKG_INSTDIR)/test-conffile"
+
+test-clean:
+ $(DPKG_PURGE) pkg-conff-forcenew