summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-normal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/t-conffile-normal/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/t-conffile-normal/Makefile b/tests/t-conffile-normal/Makefile
new file mode 100644
index 0000000..52f29c7
--- /dev/null
+++ b/tests/t-conffile-normal/Makefile
@@ -0,0 +1,15 @@
+TESTS_DEB := pkg-conffile
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-conffile.deb
+ test -f "$(DPKG_INSTDIR)/test-dir/test-conffile"
+ $(DPKG_REMOVE) pkg-conffile
+ $(DPKG_PURGE) pkg-conffile
+ test ! -f "$(DPKG_INSTDIR)/test-dir/test-conffile"
+ test ! -d "$(DPKG_INSTDIR)/test-dir"
+
+test-clean:
+ $(DPKG_PURGE) pkg-conffile
+ $(BEROOT) $(RM) -rf "$(DPKG_INSTDIR)/test-dir"