summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-normal
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-conffile-normal')
-rw-r--r--tests/t-conffile-normal/Makefile15
-rw-r--r--tests/t-conffile-normal/pkg-conffile/DEBIAN/conffiles1
-rw-r--r--tests/t-conffile-normal/pkg-conffile/DEBIAN/control7
-rw-r--r--tests/t-conffile-normal/pkg-conffile/test-dir/test-conffile0
4 files changed, 23 insertions, 0 deletions
diff --git a/tests/t-conffile-normal/Makefile b/tests/t-conffile-normal/Makefile
new file mode 100644
index 0000000..52f29c7
--- /dev/null
+++ b/tests/t-conffile-normal/Makefile
@@ -0,0 +1,15 @@
+TESTS_DEB := pkg-conffile
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-conffile.deb
+ test -f "$(DPKG_INSTDIR)/test-dir/test-conffile"
+ $(DPKG_REMOVE) pkg-conffile
+ $(DPKG_PURGE) pkg-conffile
+ test ! -f "$(DPKG_INSTDIR)/test-dir/test-conffile"
+ test ! -d "$(DPKG_INSTDIR)/test-dir"
+
+test-clean:
+ $(DPKG_PURGE) pkg-conffile
+ $(BEROOT) $(RM) -rf "$(DPKG_INSTDIR)/test-dir"
diff --git a/tests/t-conffile-normal/pkg-conffile/DEBIAN/conffiles b/tests/t-conffile-normal/pkg-conffile/DEBIAN/conffiles
new file mode 100644
index 0000000..6d57c35
--- /dev/null
+++ b/tests/t-conffile-normal/pkg-conffile/DEBIAN/conffiles
@@ -0,0 +1 @@
+/test-dir/test-conffile
diff --git a/tests/t-conffile-normal/pkg-conffile/DEBIAN/control b/tests/t-conffile-normal/pkg-conffile/DEBIAN/control
new file mode 100644
index 0000000..6dcdeb8
--- /dev/null
+++ b/tests/t-conffile-normal/pkg-conffile/DEBIAN/control
@@ -0,0 +1,7 @@
+Package: pkg-conffile
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - conffile inside directory
diff --git a/tests/t-conffile-normal/pkg-conffile/test-dir/test-conffile b/tests/t-conffile-normal/pkg-conffile/test-dir/test-conffile
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/t-conffile-normal/pkg-conffile/test-dir/test-conffile